Cannot Detect WD Passport Ultra

  • I tried to detect my WD Passport Ultra in Windows 7 and Linux Mint.

  • Tried to insert it in other Laptop but to no help. Interesting point is that i tried to download lock software and it detects a drive and shows the lock software and files but cannot open the files of the drive.

-In case of Windows 7 the drive is detected in removable notification and (create and format Hard Drive and is online) but cannot open in partition table.

  • Tried uninstalling the driver and reinstalling it. The Device is detected but cannot open.

  • In case of Linux Mint the drive cannot be mounted (installed Ntfs 3g and opened other ntfs drives)

  • Also tried to test it using WD Lifeguard Diagnostic. (Results are passed)

  • Tried using EasUS Datat Recovery.Showing Lost Drives.

Waiting for some suggestions…

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

Support by Country
http://support.wdc.com/country/index.asp

Regards,

Thanks for the reply.

I have already contacted WD support. Hope they dont suggest to wipe of my entire drive since there are valuable data inside.

I am trying to recover using Easeus Data Recovery.

Can you suggest some other solutions.

I’m in exactly the same boat…seems to be hapening to alot of us! let ,me know how the recovery program goes please?