Cannot detect my network drive at all ... its my book world edition

Tried to connect my network drive through router cannot access it  at all . Somebody please help . Contacted WD support and they told me to disable my antivirus . Ive done this no joy . Even asked IT guy in work .Any kind of advice would be welcomed . im pulling my hair out !!!

Have you had any luck solving your issue?  I am having the same issue and looking for some advice.

Can you give some more information on your setup?

  1. Which MyBookWorld - Blue Rings or White Light?
  2. What OS are you using?
  3. Is your router providing DHCP or are you using static addresses?
  4. If Windows, does the WD Discovery utility work?
  5. Did you try using the hardware reset on the unit?  For blue rings, start with power off and hold the button down after re-applying power until the LED’s are lit.  For white light, start with power on and hold the button down until the LED’s go out and the unit reboots.  In both cases, the network settings will return to DHCP so your router must be set to provide an address.


I’m having the same problem.

Im using windows xp SP3 and the HD will not Map Network Drive.

I contacted the support and they were next to useless. I cannot understand why they are not open on the weekends and close at 4.30pm!!

I have tried all the solutions, disabling the 1394 Network Connection, because someone said that would work, it didn’t. I have disabled my Anti Virus, I have Kaspersky and even added the software to my trusted site, this didn’t work! I have contacted BT regarding my router to disable the Firewall on my router, this again did not work.

I am slowly pulling my hair out.

I am considering sending the unit back. The amount of hours I have spent on trying to resolve this problem is going into days.

If anyone can help…

For drive to be mapped it must be on a network with a DHCP. Otherwise the IP will be maybe not be set at all, or to some adress by default that I don’t know and drive be not accessible.

Can you ping the drive ?

Have you got a DHCP server ?

If not try to set up a dhcp server before you start the drive. I did it worked. I set up a dhcp with one linux box then accessed to the WD and set it up to a fixed IP of my choice, after that it did work.

hey i got my drive kinda mapped . Wd discovery still doesnt recognise it though. I have the white light 2tb my book world edition . Using xp sp3 . A cisco EPC2425 router . Xbox even picks it up . Put some files on it when i mapped it , not sure if there safe though . Have contacted WD support they were rubbish told me its definitely my anti virus which i disabled . And then firewall . but nothing im at a serious dead end . Already pulled my hair out .

Had the same problem with two machines on XP.  Fixed it by first making sure UPnP was enabled (checking show UPnP devices in network view will enable if necessary, and install the windows component needed).   Then I ran freeware netscan from and mapped the drives from the list of devices detected.   There’s another thread here that explains the method.