Cannot delete iso


#1

Somehow  I have an iso file out of a folder i copied it that way then I put it into a movie folder and now I have one in the movie folder and one outside so as I scroll to the end of my thumbnails I have 2 iso files that I cannot move cannot delete. Anyone run into this or know how to delete them

Thanks

Terry


#2

I take it you’re trying to do this in File Manager?   Is this a local drive or a network share?


#3

Actually it is on a USB hard drive I have tried both right from my computer and from file manager it has an erroro code and says that the file or directory is unreadable or corrupted I can play the file through the WD live player with no problem


#4

Assuming you’re using a Windows computer, plug the HD into the computer and scan it for errors.  It sounds like the file table is corrupt.


#5

Thanks Tony problem solved


#6

NTFS is really a bad file system for hotplugging. It often has issues with files getting wrong permissions. Windows can usually correct them but that is annoying for end users who have to unplug, move drive, and re-attach.

Better is to format the USB drives with EXT2, which if a problem does occur the WDTV box can correct it since it runs linux.

There is a very good EXT2 driver for windows as well so you can use the drive when connected to pc.

http://www.fs-driver.org/

You can use any linux livecd to make a drive ext2.