Cannot delete folder from public share

Getting to the end of my teather here after what seems to be lots of issues. I am normally okay fixing these kind of things but need a bit of supprt in this instance.

Set up: iMac running mountain lion + Macbook Pro with Mountain lion, 1TB WD MBL (approx 2 years old)

My wife mentioned the other day that she was unable to save an excel document she was working on due to a permissions issue. I dismissed this and told her to do a save as to the desktop for teh time being.

When I looked in her user area, she had the folder open on the MBL where this file usually saves. To my surprise, there were 20,000+ sequentially named excel files (alaram bells already ringing). I was unable to delete them as the finder window froze.

I re-booted the MBL and the drive mounted automatically as normal - but opening some folders was slow and others prompted a complete freeze. I want to try and delete the suspect folder but it just hangs (even after leaving for a 8+ hours).

Is there another way I can delete the suspect folder? My current line of thinking is to plug in a USB drive, use copy manager to retreive files I need then re-format and start form scratch.

A few weeks agao, I had issues with Time Machine (which I have now fixed). This basically tried writing a huge sparsebudle file (600gb+) and caused extremely slow backups which eventually failed or never completed. I was able to remove the sparsebubdle file and start from scratch but I am starting to think that perhaps after two years constant use the HD may be starting to fail causeing writing issues ot the drive?

I am by no measn a computer expert, but can normally follow tech help feeds to resolve tehse kind of issues - so if anyone can help its much appreciated.

Hi Adam, I’m not a MAC guy, but you should be able to SSH into the MyBookLive using any program that supports SFTP and delete the files that way

1st you need to turn on ssh in the dashboard
Login to your dashboard through the web-browser and in the address bar change the url to read UI/ssh after the name of your MyBookLive

Turn on SSH
Find a program for the MAC that supports SFTP
login with user root and password welc0me
browse to /DataVolume/shares
browse to the share you want to delete the files from and see if they will delete
report back

Thanks for the reply.

I have enabled Shell okay and used Terminal to navigate to the problem directoy as suggested. According to my wife, there are only four or five files in this directory (a mixture of Excel files and Numbers files - none particularly big in file size). Ideally, I would want to try and keep / move / rescue these files.

As mentioned in the original post, I did catch a glimpse inside this folder which showed 20,000+ sequential excel files. These are the files I want to delete. But once inside the directory using terminal, ls -l does not list it’s contents to confirm whats in there. Trying to view in a finder window hangs for ages, then closes the window. I suppose worse case scenario is to use rm -rf and remove the directory? Didn’t want to go down this route just yet incase there was a way of saving the files I am after.

I did use a command which allowed me to confirm file deletion for each file - but again, due to the suspected high volume of files, this is going to take me forever to go through each one and confirm I want to remove it (leaving only the files I need). So I gave up on this avenue.

One other thing - I used a browser to try and use the copy manager to take off other files from the nas in case I need to re-format the drive. When using the problem folder as my “source”, instead of showing the contents, it throws up:

“Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 35 bytes) in /proto/SxM_webui/cpsync/scanshr.php on line 28”

Does this shed anylight on the problem?