Cannot delete a share: Invalid share name. (400105)

Hi gents!

I am experiencing a problem with My Cloud. When I try to delete a share I get the following message: Invalid share name. (400105).

I have tried to rename the share and I allways get the same message.

Please, does someone know what is happening?

Thanks in advance.

Charles

What’s the name of the share?

@cvaladao Are you doing the delete from the Dashboard and are you the administrator?

Watch this video and see if it helps.

Hi TonyPh12345!

The share name is “Volume_4”. I have created 2 more shares: “Volume_5” and “Volume 6”.

It is interesting to note that I always get the same error message in the Volume_4 when I try to modify any feature of Volume_4 (for instance, public access setting or even rename the share). In the other ones everything works well without getting the error message.

I am not home now. Later i will send you a hard copy of the screen showing what happens.

Hi cat0w!

Please read my answer to TonyPh12345.

I am using the Dashboard. I think I am the administrator, but not sure. Could you tell me how I can check if I am the administrator. No password is required when I access My Cloud by a navigator. that is bothers me. I have also a NAS DLink 320-L that works fine. Passwords are required both to use its dashboard and access data.

Anyway, I believe that the issue is related to a data corruption of the share properties. Does it make sense to you?

Typically the administrator has a little green check on the user name in the User section of the My Cloud Dashboard. To force using a password when accessing the Dashboard one must give the administrator account a password. Which is also done in the User section of the My Cloud Dashboard.

Hi Bennor!

I am administrator. Thanks for the help!

image

When I try to rename the share I get the same error message:

image

image

@cvaladao Would creating a folder in the share Volume_4 and naming that folder Volume_4a work for you? You could move the information you want to that folder.

You should be able to do the same by creating a new share named Volume_4a, just cut and paste the information to it if you are allowed to create a new share with that name.

It appears you are running the v4.x firmware due to the Safepoint tab. I cannot even create a Share named Volume_4. I get the same error (invalid share) on my v4.x My Cloud. So it begs the question. How were the Volume_4 Share name created if the Dashboard won’t let the user use Volume_4 as a Share name?

On my v4.x My Cloud I cannot use; Volume_1, Volume_2, Volume_3 or Volume_4 as Share names via the Dashboard.

I think you have a good clue. I am using v04.05.00-334. For sure I have created the share in a previous version. After I updated the firmware, I cannot change any property of this share. What a mess! I am quitting. I think I am going to use cat0w’s sugestion.

Thank you very much!

I think the only alternative that I have is to do what you suggested to do.

Thank you very much.

Try SSH’ing (using Putty for example) into the My Cloud, navigate to the Share folder, and see if you can rename the Volume_4 folder. Then reload the Dashboard to see what it shows. To SSH into the My Cloud one has to enable SSH in the My Cloud Dashboard > Settings > Network page.

That will possibly break other stuff. The share names are stored in an internal database. That file is read and is used to write the various configuration files (like Samba) when changes are made.

My guess is that later versions of the 4.x code introduced a prohibition against certain share names but was too silly to check if those shares had already been created.

I think the only “real” fix will be to get your data moved off the drive entirely, then do a full factory restore, and start from scratch. :frowning: