Cannot create folder named ‘uploaded’

Firmware Version : 2.31.174
Backing up website folders fail because ‘uploaded’ is a reserved folder name (which is very short sighted of WD)
accordingto a post 6 years ago (https://community.wd.com/t/weird-file-naming-bug-with-my-cloud-ex4/97263)
this was reported and would be fixed with an update.

Will it ever be fixed?

I doubt it. Seems the only thing WD is updating on this product is security fixes.

@KEN_BALDWIN are you trying to create a Share named “Uploaded” or a folder within the Share itself?

You could possibly edit the smb.conf file to allow it, but I’m not sure if it survives reboots or not:

https://www.samba.org/samba/docs/current/man-html/smb.conf.5.html#VETOFILES

Here’s the relevant line:

veto files = /:2eDS_Store/.bin/Network Trash Folder/.systemfile/lost+found/Nas_Prog/mirrored/uploaded/.wdmc/

Where is this folder located? I just created a share named uploaded without any problems. See image below.

You can ssh into the my cloud and create the file. But if you look at the /etc/samba/smb.conf file you will see that the uploaded is in the veto parameter.
The smb.conf file gets recreated on every boot. The command smbcmd or smbcom recreates the basic smb.conf. The there is a file in /mnt/HD/HD_a4/.systemfile/.smbm.xml This file contains the changes made to the basic smb.conf file.

I’m pretty sure he’s wanting a folder named uploaded, not a share. … He said his backup failed on that folder name.

‘Uploaded’ is a common name in a website folder hierarchy. Daily backups of websites fail when trying to create the folder.

I will ssh into My Cloud and see what I can find, thanks for the tip.

Alternatively I will have to try a work around by excluding the root of the website from the backup but auto run a script so as to zip it up prior to the backup.