Cannot create folder ".bin"

Doesn’t matter how I try to create it, I get “The system cannot find the file specified.” if I try to create a folder called “.bin”, from the command line, from explorer, by renaming an existing folder, or via any kind of copy operation. I can ssh onto the box, create a folder .bin/ manually, chown/chmod it to look like the others, but it still doesn’t appear in the share (cannot see it, cannot cd to it).

It seems similar to this EX4 issue, except I can create a folder called “p2p”. “.bin” is the only one I have found that I can’t.

This stops me backing up nodejs modules.

I’m using an EX2 Ultra, firmware 2.30.174. The share is private and has media serving switched off.


Might be because SMB considers files or folders beginning with a dot to be hidden so you’ll need to enable hidden files in explorer to see it.

Hi Tony,

Thanks for the reply. I can create a folder called “.lemon” without problem, so it’s not the dot that’s the problem. I have lots of files and folders starting with a dot, but it’s only “.bin” that fails.


Ahh. Here’s the issue

veto files = /:2eDS_Store/.bin/Network Trash Folder/.systemfile/lost+found/Nas_Prog/mirrored/uploaded/.wdmc

That name is vetoed for some reason…

Ah! That’s helpful, thanks!

Yup, that’s in /etc/samba/smb.conf. I can understand “lost+found”, but I suspect some of the others relate to stuff the DLNA or iTunes services don’t like you messing around with. If so, it probably shouldn’t be global, but per-share and tailored to what options you have on the share.

I’va taken a backup copy of smb.conf, and edited the file to copy that line into the section for the share concerned, removing the reference to “.bin” (and to “uploaded”, as I can see me using that as a folder name unwittingly). Then “smb restart” and all is well.

I have a feeling this might not survive a reboot, or the slightest sniff of the share settings in the UI, but for now it works. With any luck, WD will make a slightly smarter version in a future upgrade.

Thanks for that, Tony!