Cannot copy to WDTV Live attached USB drive


#1

Hi everybody,

i brought a WDTV Live box some month ago. I have to say i’m very happy of this little piece of hardware, it works great for my purposes.

I use it cable-wired to my router, a NetGear DGN2000, and i’ve attached a 1TB WD Passport Hard Drive.

Through the wireless network i browse the WDTV live (i mean, the attached drive) from 2 different WIN7 laptops with no problems at all… can copy files from and to, can stream almost everything… this until a couple of days ago!

I am ABSOLUTELY sure that nothing happend in the time between the WD worked and now… i wasn’t even at home, so nothing has changed.

What i noticed is this:

At first, i couldn’t even browse the drive, my win7 laptop kept saying every time the same message:

“cannot find wdtvlive in the network” (i have an italian OS, don’t remember exaclty the english messages).

After a factory reboot on the WD, i can now browse the hard drive attached, but i cannot stream or copy anything to or from it.

If i try to copy a file from my PC to WD Drive, it stucks there like for ever (at least 5 minutes) and then it comes out with “A network access error has occured”. This happens with any kind of file-size, from 1Kb to 1Gb.

If i try to copy a file from WD Drive to my PC, i can copy it (in a loooong time) only if the size is less than 10 MB, otherwise same network error.

I can create a folder on the WD Drive.

I can create a text file on the WD Drive, but it takes something like 10 minutes…

If i try to connect with my WDTV Live to youtube, or flickr, or some other serivce available from WDTV Live Box, it keeps failing. The message is “the folder has no content”.

I have tried almost everything now, and i don’t know what to do more…

I have reset to factory the WD more than once, without success…

I have reset the Router to factory default either, but nothing changed. AT ALL.

Using DHCP or static address on WDTV Live seems useless… same result.

I have to say that i’m really pissed from this issue… it never had one in almost 3 months, and i was really happy…

If somebody can help me sort out this issue, i would be very glad.


#2

Welcome to the forums.

Is this the ONLY problem?  Are you able to play files from your net shares okay?  (Or do you even use net shares?).

One thing to check for is to see if somehow Windows Live ID assistant got installed on any of your computers – this can even happen automatically (with a behind the scenes update) and will indeed stop many network type activities from occuring (do a check of all your machines for this).  Unforutnately, even removing it won’t solve the problem (you’d have to restore to a point before it ever got installed, most likely back when your system was working properly).


#3

Hi mike,

and thanks for your reply.

Well, while i posted the message, i tried to connect to a network share on my Win7 Laptop, even if never use it (i don’t need it, because the HD attached acts like a media storage in the network).

Result is: WDTV Live CAN connect to the share, and browse the contents at a speed that is absurde, i mean sluggish is not appropriate for the slowness. I tried to launch a file about 35 minutes ago on the WDTV, and i’m still waiting to see something. So i guess that even network shares are not ok.

But it seems to me it’s a problem of the WD TV rather than a pc issue. What i mean is that if Windows Live ID Assistant would be the problem i could not use the WD since the beginning because i have it installed long before buying the box.

Also, i can copy files from and to both the Laptops.

The only hardware is not working is WDTV…

have to say i am quite desperate…

One thing i set up during the first installation is automatic update, and now the box is updated to V1.0.2.21

do you know if i can re-run the firmware update, maybe by downloading it from the WD website and using the “manual procedure”?


#4

I use it cable-wired to my router, a NetGear DGN2000, and i’ve attached a 1TB WD Passport Hard Drive.

 Through the wireless network i browse the WDTV live…

So which is it?   Wireless or Wired?

 I am ABSOLUTELY sure that nothing happend in the time between the WD worked and now… i wasn’t even at home, so nothing has changed.

You CAN’T be sure.   Obviously, SOMETHING changed, by definition. 

If you’re on Wireless, there’s ALL SORTS of things that could have changed in your environment.


#5

Hi Toni,

it seems now that the issue is solved.

As you rightly said, something probably changed, but not in the way you suggested, i mean, it seems it wasn’t a network issue at all.

RE your questions:

i have the WDTV Live wired cabled.

I use wireless network ONLY FROM my laptops TO the WDTV Live.

After trying several reset / net config / laptop config and so on, without any success, it came across my mind to check the status of the HD.

When i plugged in for the first time, i ran a full disk check and a defrag, just to be sure that everything was ok.

I did the same thing today.

The scan disk was ok, and the defrag analysis resulted in a 16% of fragmentation. I ran a full defrag (from the laptop, off course), plugged in the disk back to the WDTV Live, and now it works fine as always.

I’m sincerely happy that it came back to normal, but i have to say that it’s quite awkward that the WDTV OS can’t handle a 16% of fragmentation… and it doesn’t even have a disk utility to scan / defrag and so on the attached drives…

maybe in a future firmware version will WD put something in?

:smiley:


#6

Hee hee…   I doubt we’ll ever see Disk Utilities on the WDTV’s…  

Depending on the magnitude of fragmentation (and 16% doesn’t really tell you much; it just means that 16% of the blocks aren’t adjacent.)  If 1% of a file is fragmented, but the consecutive blocks are on opposite ends of the platter, that will be worse than if it’s 30% fragmented with the blocks on adjacent tracks.

Fragmentation on portable drives can DESTROY performance.   

At any rate, I’m glad you got it squared away, and thanks for posting your follow-up and conclusions.  It’ll hopefully help people who come searching.


#7

Hi Tony,

as we use to say in italy, i sang victory too early…

still got the problem, BUT it seems i found the final solution.

As i told, i have a DGN2000 NETGEAR Router @home, and after a couple of lookups on the web, i found that this filthy hardware (or at least a stock, one of which i have unfortunately bought) has the tendendcy to break up the lan ports for too much usage!!

No words to say… after two years of honorable service of my old Roper unit, i have chosen netgear on friend suggestion and because of its reputation in being hardware-robust…

Anyway, i have made a phonecall to the customer client service, and they’ve confirmed that this issue can happen, from one minute to another. I will now send the bloody thing back, waiting for a new one.

Off course i’ll keep you posted.

In any case, defrag and scandisk solved at least 1 issue… now the box is faster than ever!