Cannot copy files across network through WD Live

Hi there,

I am having a problem with my WD Live in that I can’t copy files from my wirelessly networked laptop to the external hard drive plugged into the WD Live.

I have read most of the relevant posts on the forum and think I have got everything set up okay.  However, I feel like I am missing something somewhere which is creating my problem.

I have the WD Live connected to my Dlink  router via an Ethernet over power adaptor. I have an external hard drive plugged into the WD live which has all my movie, music and photo files.

My laptop wirelessly connects to the router and the network and  I use the WD Live shortcut on my desktop to access the external hard drive connected to the WD Live.

The laptop is able to ‘see’ the WD Live on the network as well as the external hard drive connected to it.  I can access the external hard drive through the WD live and navigate through the folders on the external hard drive.  I can move movie files around from folder to folder on the external hard drive. From the WD Live I can also access the shared folder on the laptop.

I seem to be able to copy small files over on the wireless network such as photographs, and get these onto the external hard drive through the WD Live. My problem is if I download a movie onto the laptop, I can’t seem to copy it wirelessly to the external hard drive.  It works very, very infrequently and 95% of the time tells me there is a problem with accessing the network. I then have to unplug the external hard drive and plug it directly into the laptop to transfer the new movie file over

I had thought that the network must be setup okay if I can move files around on the external hard drive. I can copy photo files back from the external hard drive through onto the laptop.  However, I cannot play a movie file back through the network or even play music back from the external hard drive onto the laptop.

I believe I have all the network settings and sharing settings correct on both the laptop and WD Live.  The network test works fine on the WD Live and I am able to view Youtube movies on this.

The laptop is running Windows 7 Home Premium. I run Nortons 360 on the laptop and have disabled the firewall with no change.

The router is a DLink 604T.

Am I dealing with a general networking problem or is it the way I have the WD Live setup?  Is there anything else I can try?

Any thoughts or ideas would be appreciated.



Darryl Lennane
New Zealand

I now have a new win 7 laptop and am running into the same issue. I will have to figure out this frustrating OS to get it working and will post what’s up. The thing that really bugs me, is my other desktop, that runs lucid, works just fine and all networking works great. **bleep** windows.

1 Like

Have you mapped the external drive connected to the WD TV Live?  If you are trying to move files just by accessing its folder in Network Places, you may have issues with it.

1 Like

Hi Bill

Do you mean by mapping through My Computer?  Yes - I Have done this and tried copying files to the drive this way.  Again, I seem to be able to access the folders but copying a movie over gives the same eerror message that there is a problem accessing the network.

Any other ideas?



1 Like

I think we have gotten confused here. 

From within the WD TV User Interface, you should be able to move the files from your computer to the external drive connected by USB to the WD TV.  However, you have to have the folder on the computer, that you want to copy from, set up as a share.  That includes making sure that it has all the permissions set up that will be required to do this. 

However, you cannot do the copying from the computer to the external drive connected to the WD TV Live.  That’s problematic at least.  If you’re trying to do that, then that’s why you’re having problems.  You must do the file transfer from either the computer to the external drive if it’s connected directly to the computer; or from the WD TV Live by way of the computer’s shared folder to the external drive connected to the WD TV Live.

1 Like

Hi Bill

Copying from the computer through the WD Live to the external hard drive is exactly how I’ve been trying to do this.  Why is doing it  this way problematic?

I’ll try it the way you have described.



Are you doing it by copying from a network share on your computer to the drive connected to the WD TV Live?  You have to make a folder you’re trying to copy from a share, or it won’t work.

I have been doing exactly that from an XP machine for months - opening the HDD on the WDTV as a network share, and copying to it from windows…  I now have a win7 machine and although I have mapped it ok and can read files from the HDD on the WDTV, I can no longer copy to the drive from the PC.

I stumbled on a security setting in Win 7 which turns file sharing encryption down to 40 something bit from 128,  There is also a setting to allow anonymous access if you want it.  Finally I tried copying from the PC using WDTV file management - and that worked.  Still unable to initiate the copy from the PC end, but better than nothing.

I can’t think of anything else.  Maybe the link below will shed some more light on permission issues.