Cannot connect via FTP from outside


#1

Hi,

I have a question - hope someone can help ![:smiley:]( “Smiley Happy”)

Here’s my setup;

1TB My World Book Edition II (white light) - connected via ethernet to the router at home;

  • Home gateway with WAN address updated through DynDNS (address: somebody.homedns.org) and doing port forwarding of the FTP (same port as the one configured on the NAS)

  • Windows XP laptop 1 running Filezilla outside home;

  • Windows XP laptop 2 running a browser (Firefox) outside home

The problems in laptop 1 is:

I cannot connect via FTP.

Reason: My Book World Edition retireves the internal IP address instead of somebody.homedns.org

Command:    PASV
Response:    227 Entering Passive Mode (192,168,1,69,19,234)
Status:    Server sent passive reply with unroutable address. Using server address instead.

The problems in laptop 2 is:

I can navigate through the Twonky Media library, but I always have to replace the NAS internal address by somebody.homedns.org every time I go up or down in the library tree

Reason: same reason

Could you help setting up the NAS accordingly?

Thanks,

Joaquim.


#2

Hi there, are you sure your ISP is not blocking the FTP access? o.o

Try a local FTP first just to check by doing the following on a browser:

ftp://admin@NASIPaddressontheRouter

If you can’t access it then double check the ports and the MBW is working fine, if you can have FTP that way then move on to try a vanilla FTP access from Firefox with the following syntax:

ftp://admin@xxx.xxx.xxx.xxx (where xxx is your public IP address)

If you get error 530 then you need to contact your ISP.


#3

Local access: OK

Using WAN IP address: error 425

NAS asks for the password and then after a few seconds connection fails.

The problem is: NAS returns back its own local IP address and not the WAN address.


#4

Shall I install inadyn to solve the problem?