Cannot connect to wireless-N


#1

Hi,

I’m using a Hi Power Wireless Mini-USB Adapter GW-USMini2N to connect my WD TV Live. But it seems like it only works in G mode. When I switched the router to N mode  it cannot connect to the network. Anybody have the same problem?


#2

Are you using Firmware 1.01.11. I believe that support for this adaptor may have been added with this firmware as it is labelled new on the supported list.

You also say that you set up the wireless and then changed the router to N. Perhaps you could try setting up the wireless connection again as it may have defaulted to G on the WDTV. Of course it may also be an incompatible router.


#3

I’m using firmware 1.01.12 and Linksys WRT160N v3 router. I did try to connect again after changing the wireless mode. It worked with Mixed, Wireless-G only, Wireless-B only but not Wireless-N 

Thanks


#4

Try reconnecting using the manual option. Does it see your wireless SSID.


#5

Yes it can see the SSID. I setup the wireless connection again every time I changed the wireless mode. It worked with the other modes but not the N mode


#6

Interesting. It works if I disable my Wireless security. But that’s not useful