Cannot connect to WD My Cloud (dropping off network?)

(I realise there are similar topics but not sure if outdated and no instructions are clear enough for me to follow unfortunately - apologies)

Current setup:

  • 4TB WD My Cloud
  • MacBook Air running OSX 10.11.1 (El Capitan)
  • router is a Virgin Media Super Hub 2ac (I’m in the UK)

I want to use the My Cloud as a 2TB remote backup drive (using Time Machine to perform the backups), and the other 2TB as a cloud (to access work / music / photos / videos across locations - work, home, friends). I believe the My Cloud should be able to do this. However when I try to start a backup I get an error message:

Back up disk not available
Try backing up again when “WDMyCloud” is available

Similarly when I try to connect to the shared drive “WDMyCloud”, I get the error message:

There was a problem connecting to the server “WDMyCloud”.
The server may not exist of it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.

I don’t know how to check the server name or IP address, but the network connection is fine and I have tried rebooting the My Cloud drive to no avail.

I’ve seen some discussions recommending setting up a static IP address for the My Cloud. I don’t entirely understand how this helps (?), but am willing to try it. However I need basic instructions. I also understand I have to change the settings on my router to enable this? Instructions for that would also help. Do I need to do anything else then?

Appreciate any help! Thanks,
Hugo

If you cannot reach your My Cloud (on a Mac) via the My Cloud name (typically “mycloud”) via a web browser. There are a couple of ways to find the IP address used by the My Cloud. One way is to download the WD Access for Mac which should discover the My Cloud on your local network (and I assume show the IP address for the device). The WD My Cloud Setup for Mac may also be able to find the IP address of the My Cloud on your local network. If the WD My Cloud Desktop for Mac is anything like the PC version it too should discover and show the IP address of the My Cloud on your local network. A second way is to check your router’s administration page and see what IP address it is handing out to DHCP clients including the My Cloud. Another way is to download a free network scanning programs from the internet that will scan your local network and display the various devices and their IP addresses.

Once you have the IP address in hand, use that in your web browser to access the WD My Cloud Dashboard UI.

Once you gain access to the Dashboard you can configure the My Cloud for a Static IP address. See either the My Cloud User Manual or the following WD SUpport document for how to set a static IP address: How to configure a My Cloud or My Cloud EX4 drive with a Static IP

Note: there is a big El Capitan thread discussing the various issues with El Capitan and the My Cloud.

https://community.wd.com/t/support-os-x-el-capitan/96744

Thanks Bennor. To recap, my problem is that I cannot connect to My Cloud (reason unclear to me).

As a first step I’ve set up a static IP address on both my router (Virgin Media Super Hub 2ac) and the My Cloud.

I still wasn’t able to access the My Cloud from my laptop (Apple MacBook Air). I checked the Settings on the Dashboard and under General found that the Connection status said “No internet access”.

I rebooted the My Cloud but no change.

Any other suggestions?

If you have manually configured a static IP address within the My Cloud Dashboard, ensure the Gateway IP address is the IP address for your broadband router/gateway. In some cases one may have to set the DNS addresses to the same value as the gateway. Or they can try using public DNS servers like Google’s: 8.8.8.8 and 4.4.4.4.

Generally the “No internet access” means there is something wrong with the network settings either on the My Cloud or on the broadband router/gateway. It typically means the My Cloud cannot send traffic to the internet.

After over three years of struggling with three different WdMyCloud Drives, the only one way I’ve found to solve this problem is: Walk to the device, pull the power plug, wait a few minutes for it to spin down, re-plug the power, and wait ten to fifteen minutes for it to reboot and self-test before it finally comes back on line. Nothing else i’ve tried (and believe me, I’ve tried a lot of solutions) will bring your WdMyCloud back on line any faster than this. My Cloud drive continually falls off my network, at least once a week if not more. WD has a serious issues with their Cloud drives and the accompanying software. There’s no excuse for this and no matter what WD offers up, don’t buy it. The issue clearly falls at their feet.

My device never drops off the network. So I suspect yours is some complex interaction between MyCloud and your network devices.

If this was a universal problem with all MyClouds, we’d see more than the odd complaint every nine months or so.

I agree 100%. I’ve battled with setting up these drives for too long. We have two units, 1TB and 3TB and both with continuous unreliability fall off the network for no apparent reason. After trying to resolve these simple issues, we’re replacing them with another brand, probably into a NAS unit. I can’t understand why WD can’t resolve this with an update as there seems to be plenty of people with the same problem.

This can be solved by a simple cronjob , that pings router IP address every 5 minutes and if if fails restarts the network connection (dhcpcd or dhclient). I am not able to provide exact script as I am now running debian on mycloud but someone with linux experience can do that. This may go something like…

*/5 * * * * ping -c 1 192.168.0.1 || dhcpcd <default options>

one can find how dhcpcd is running by using

Set to Static IP. Enabled UPnP in my router. Found this on the internet:
Fix the WD My Cloud Disconnect

What you want to do to fix the intermittent disconnect of your WD My Cloud is to change it’s network connection from DHCP to Static IP.
Reserve an IP on the Network

First, login to your router where you want to reserve a local IP address on your local network for the WD My Cloud device.

This step will differ from router to router but the concept is the same and if you aren’t sure how to do it, you can search your router’s documentation to get instructions.

My router is a TP-Link TL-MR3420. With my router, I go to DHCP > Address Reservation where I’ll fill in a MAC Address and the IP I want to give the device on the local network.

2015-09-04_01-03-08

The MAC Address can be obtained at the bottom of the WD My Cloud drive. Literally pick it up, turn it over and you’ll see “MAC Address: XX:XX:….” at the bottom of it on the sticker. Then fill in an IP that is in your local network range.

Save the settings and reboot the router if needed for the changes to take effect.
Configure the Static IP on WD My Cloud

To do that, go to http://wdmycloud.local and login as a user or administrator. Then navigate to Settings > Network > Network Services.

For the “Network Mode” setting, it is most likely set to “DHCP” which means it uses it’s host and automatically determines it’s IP address from there. So choose “Static IP” and you’ll see a dialog come up which allows you to fill in some settings.

2015-09-04_00-59-20

For the IP address, fill in the local IP address that you reserved earlier on. And for the Netmask (subnet mask), you’ll most likely fill in 255.255.255.0 unless you’re using something different on your local network as the mask.

2015-09-04_01-07-09

That’s it, save the settings by clicking “Save“. The WD My Cloud will become unresponsive as it restarts it’s network firmware/software and connects using it’s new, static IP address. Be patient and give it some time.

I followed these recommendations and I have not had the dropping off internet problems so far. Before it was constantly dropping the connection. Very frustrating. Hope this helps you.