Cannot connect to NVM after Ipad application updated

After the latest ipad update to Version 1.2.1 I can no longer connect from my iPad gen 6. It hung forever on the previous IOS version 14… so I updated to IOS 15.1.

I removed the Ready View app and re-added from the Apple store and it goes through the setup but when I give it the QR code it just hangs forever.

I unplugged my Ready View system for over a minute and let it restart. Same results as above.

Edited: Note I can connect from a different Ipad that has NOT been updated and I can connect from my iPhone 7 that has NOT been updated.


I am having the same issue it works fine on my IPhone that is still running 1.1.8 but the IPad with 1.2.1 does the exact same thing you are describing. Looks to be an issue with the 1.2.1 update.


Thanks for the confirmation. I hope that they fix this soon. I’ve turned off auto-update on the two devices that still work.

Exact thing happening to me. What’s the fix for this? Is WD monitoring this conversation and these problems question. That update must be defective.

1 Like


My iPad updated to iOS 15 and my ReadyView app on my iPad updated to 12.1, not the app does not work. I tried uninstalling and reinstalling the app. Not sure if this was an iPad or WD app issue. Does anyone have a fix? Thanks

I hope that they are monitoring - I just woke up a chat-bot on their support site. I don’t know if I am typing to a human or a chat-bot. Perhaps someone will notice and check out this forum.

1 Like

I think that I was chatting with a human. They put me off to MicroCenter as their business partner who handles these issues. – from the chat below:

XXXXXX, the support for the WD ReadyView product is now handled by our business partner Micro Center who can be reached by phone at 614-850-3670.
We used to handle the support but it's ended and is being handled by Micro Centre that's why I suggested Micro Center as they are handling the support for ReadyView now.

Good luck all, I hope this gets fixed.

1 Like

I’m going to contact their tech-support people at a phone number that I inquired about another issue a few months ago. I will try to get somewhere with them today.

Any updates?

I called them and stayed on hold for 30 minutes and they never came on. I can’t get in touch with a live person to find out what’s going on with the app. They should be coming out with a new update but he knows when that will be.

So on December 9 WD installed a new update 1.2.2 to my iPad. This update did not change anything. Has anyone else checked their iPad to see if the app is functioning correctly. To date mine is not. I probably should have checked the app rating at the App Store before I purchased these cameras from Redi view. I will not make the same mistake twice. If they cannot correct this problem the cameras are no use to me. I will start shopping for a better company to deal with.

I finally received a response from WD, they are not planning on an update to the app.

I called my IT person, since the cameras are capable, we purchased a Ubiquiti 8 port switch, we deleted the WD readyview app and we use Blueiris app. Everything works as expected, and the app works on my iPhone, iPad, and desktop.

That is what we did.

The updated iPhone and iPad app version 1.2.2 works perfectly on both of my devices (iPhone 11 and iPad Air). The app version 1.2.1 didn’t work well, but this latest update to 1.2.2 fixed it. WD is no longer supporting the system, Microcenter is. Microcenter works with the app developer and instituted these most recent updates. I called Microcenter and they stated that they will continue to support the WD Readyview system and app and have no plans to discontinue it anytime soon.

I had an issue with my iPad Air 2 accessing the cameras back in November. I’m not sure if it was before or after the app update (1.2.1) that occurred in the second week of November. I ended up deleting the app and reinstalled it, when I started the set up, I get the spinning wheel of death. I have deleted/reinstalled the app multiple times and can never get past this point. My assumption is as a “new” setup it is using the default password to log in. That won’t work since the system is already set up and a new password has been created. I did try to change back to the default password to test my theory, but the system prevents you from changing back to the default password. Next thing I tried was to reset the system to the factory default which restores the default password. That didn’t work either since they force you to change the password before you can do anything. If I could get into the startup settings maybe that would help, but I see no way to do this. Perhaps an app developer would know? At this point my iPad is useless for use with the ReadyView system. The good news is the app on my iPhone 7 still works. Let’s hope someone from Micro Center sees this thread and provides some guidance.

You make it sound like an easy install. How much trouble did you have getting this to work on your WD? is there a cost factor involved with getting this app?