Cannot connect to network shares with SMP LIVE

I just bought a WD Live SMP to complement my 2nd gen WD LIve which works flawlessly. I connected the SMP unit to my network through wifi and it loaded up my network shares perfectly. This was a month ago. Last night while watching a video, it stuttered and then froze. I rebooted the SMP unit and all of the network shares from my W7 64x computer were gone. I tried to reload them but I kept getting the error message that the files could not be found. I have researched this issue and found that many people have had this issue. I have the latest firmware, but rolled back to see if that would fix it- it did not. I reset to default settings as well as check the matster Server set up whereas my W7 unit is. Can anyone out there tell me how to fix this issue?



What about the other media player that you have? are you having the same issue with or just with the new unit?

What about the work group? stills the same?

Have you tried reseting the router and the computer?

Yeah, I actually figured it out on my own. it was only happening with the new SMP version device. I remembered reading somewhere a while back that the SMP does not like when the computers on your home network are set up with the “Homegroup” feature in W7. I disabled it and now the network shares work fine. It seems odd though that it took the SMP unit over a month to detect this and kick my shares out.

Thanks anyway- I’m surprised that more people have not had this issue.