Cannot Connect to MyCloudHome

The funny thing is even though app says offline and white light is flashing on it? My Plex server on it is still functioning and I can watch movies. So proves it’s working just not the files access !

1 Like

Lucky for you. My Plex stopped working too

1 Like

I ‘stumbled’ on this page – not easy to find. Shows the status of the service. Hope they resolve it soon.


It shows device as offline on the iOS mobile app and over the web too. However, I’m able to access the device within the local network.
Device Led keeps flashing as if device has no internet connection.

Doesn’t look like we have received a response from WD on this. The same thing is happening to me. I have two MyCloud drives. One for work and one for personal. Both are showing as OFFLINE but are certainly not off line. The internet is working great for all other resources. My personal network is working great for all other resources. I’ve rebooted each drive. Swapped out the ethernet cords. Nothing is working. Finally I tried to connect them directly to my computer. My computer will not recognize them. I opened a ticket. Fingers crossed they can resolve this issue. I’ll share if they do.


I am having the same issue with mine… I have been online with the customer service chat that keeps stopping when the queue gets down to about 25 left… :frowning: I have tried restarting everything and unplugging the home cloud, as well as all devices connected to the home gateway. even uninstalling applications… still shows as “OFFLINE”

Same issue. I have 4 units hooked up and they all shut down one after the other. I can still play my Plex stuff off of them (thank goodness) but cannot access them on my PC to add content.

Thank you for the infomation friend! MUCH APPRECIATED!! :smile:

thanks a lot for the info! I was about to panic a little :smiley:

1 Like

With this outage, I tried to connect my cloudhome directly to my desktop using ethernet to access some files. Yet, I was not able to map it in windows. Is it how WD designed it? Can someone enlighten me pls.

1 Like

Response for ticket I raised with WD Support.


Thank you for contacting Western Digital Customer Service and Support. My name is Emma S.

Thank you for reporting the issue with our Cloud Services. We are aware and working to resolve the issue as quickly as possible.

We apologize for any inconvenience this interruption may have caused.

Emma S
Western Digital Customer Service and Support


I have the same problem, cannot access.

نفس الشيء

1 Like

I have the same problem, pls help me…!

WD Contacts FYR

Looks like we can’t do anything but wait…
As there is no estimated time when will it to resolve.
Should have made a backup yesterday :woman_facepalming:

Hi i am in NZ and the same thing has happened here, white light is on but pc is telling me its offline and cant access data…love this device and need it back hopefully will not be too long. To be fair its not been an issue for the past few years and am sure they are trying their best in these difficult timea a, sending them positive thoughts …

same on mexico…breathing light since this morning (sunday, sept 30th)…no access neither from PC or mobile app…

If you have the drive mapped, you may still be able to access it through windows Explorer.
I rebooted my MyCloud home and lost the mapping on one PC, but my laptop can still see it.
If you have files you need, it might be worth copying them somewhere else in case you lose the mapping later.

1 Like

too late for me…a very desesperate guy on this part of the world…i already make a (possibly it fails because it wasnt connected to WD servers) hard reset pressinng up 60+ seconds and still same behavior :slight_smile:

any info about how long is it gonna take to repair?