Cannot connect to MyCloud Dashboard over wifi

I cannot connect to the MyCloud Dashboard over my home wifi network. I can connect, however, using the one computer in the house that is connected to the router via Ethernet. I’ve tried everything I can think of, but I’m out of ideas. Can anyone help?

Do you have AP Isolation enabled on your router?

If you’re computers are running Windows OS then make sure they are all in the same workgroup as your My Cloud.
More details about each device will help. Have you looked at the User Manual. Use link below.


Yes, I have read the manual. Yes, the computers and the MyCloud are in the
same workgroup. It still does not work. Please escalate to Tier 2.

This is a user to user forum for the most part. If you need “Tier 2” support it is recommended you contact WD directly:

As was asked above, is AP Isolation enabled within your router or gateway? Are all computers and My Cloud using the same IP address subnet? For example do all devices use an IP address range similar to this: 192.168.1.x?

Sorry for the Tier 2 request. That wasn’t meant for this forum. No, AP isolation is not enabled. Yes, all devices are using the same subnet. I don’t understand why the ethernet-connected computer can access the dashboard, but the wifi ones cannot.

If the WiFi computers are all running the Windows OS, check to ensure the WiFi “network location” configuration is set to “Home” on Windows 7/Vista/8/8.1 and is set to “Private” on Windows 10.

When a WiFi network location is set to Public on a Windows OS computer it will limit or block the ability to access or scan the local network for other devices. Some links:

How to change Windows 10 network location from Public to Private

Choosing a network location

How to change your network location from public to home

  1. Confirm your MyCloud IP from the PC that you can access.

  2. Find out the IP of your Wifi device i.e. from the network adapter or ipconfig/ifconfig.

  3. Do they belong to the same submask? I.e.

  4. Can you access MyCloud via its IP i.e. http://192.168.1.x/UI from the Wifi device?

If you can access via IP then it’s a NetBIOS thingy, check your network adapter that NetBIOS over tcp/ip is enabled and active. Some device such as Android doesn’t do NetBIOS name resolution. Some routers are able to define a name for each device which will help to resolve hostnames.

Yes, my computer and the MyCloud are on the same subnet. I cannot access the MyCloud via its IP address from wifi, but I can access it from my ethernet-connected computer.

  1. Can you ping your wired device from the wifi device? See the shares etc.

  2. Can you see the shares or even ping MyCloud IP from the wifi device?

I hope you’re not connected to a guest wifi mode if you have one.

You didn’t elaborate what you have tried, also the info given was limited, setups, OS, router specific etc. So it’s kind of tough to resolve this because there should be no issues devices seeing each other between wired and wifi if both device are on the same subnet except if there’s some AP/Bridge/Guest/VLAN mode that needs to be configured.