Cannot connect to my home internet with WPA2 AES but can connect in WPA2 TKIP

Hi all,

I’ve have thie problem for quite a while, but now I finally have enough…

My box in fw 1.08.xx and I have trouble connecting to the internet through my airlink 300N router. When the password security is set to WPA2 TKIP, I have no problem at all, but when I set my network to WPA2 AES (more secure and also can achieve 300Mbps), my box have trouble getting the IP from the router. I am sure the setting is correct, because sometime using the same setting (AES) I can connect. Once I can connect, I can watch a movie in netflix smooth without issue. But once the box is turn off (not reset), then it doesn’t work again. I think 1 out of 50 times it will work.

I check the log in the airlink router, I see the router sending ack and giving the ip to the box, but the box never take it (never receive anything back from the box once ack is send from router) when search for available network my network shows up no problem. But it almost always fail after a long spinning arrow.

Anyone have this issue? Does WD TV Live have trouble using AES encryption? Does that related to distance? (But should not be since there are case where the same setting and same distance work, and once it work, it can function normally)

Thanks in advance.

Have you tried setting a manual IP number for the WDTV? Also try installing the latest firmware version (1.11.14).

I tried the manual IP. I even tried to set a fix ip to assign to the WD box in my wireless router so that everytime the router see this device (MAC address), it will assign the static ip to the device. That doesn’t work. I am unwilling to upgrade to later fw as I see a lot of people complaining for the new fw issues. I don’t have any issues (playing files, etc.) and I am happy the way it is, WHEN it is working that is.

Because it did worked sometime but not all the time, I think there is some handshaking problem between the device and the wireless router (airlink 300 N) when it is WPA2-AES (when it’s WPA2-TKIP it works fine too). Since I don’t have other issue with other devices (laptop, desktop, iphone) connecting to the router, I assume the problem is in WD TV side.