Cannot connect to My Cloud after switching ISP

Hi, I recently changed from Comcast/Xfinity to CenturyLink Fiber. With the new router, I cannot access My Cloud. It seems that my new router is not seeing MyCloud. The MyCloud is connected to the router; the blue light in front is solid, and the green light in back is also solid.

I do not know what to do next. I found a few posts on here that described a similar issue, but the solutions provided were not helpful or relevant. I still have the Comcast modem, so should I use that to access MyCloud, and “reset” stuff?

Please advise, and thank you.

@WD_Admin

Is the My Cloud connected to one of the networking ports, not the WAN port, on the router? Typically there will be four networking ports on a ISP router and you connect the My Cloud to one of them.

Next, if you have previously configured your My Cloud with a static IP address within the My Cloud Dashboard, that IP address subnet may be different than the subnet used by the new router. Performing a 4 second reset should reset the My Cloud IP address setting back to default so it pulls an IP address from the router.

How to Reset a My Cloud (single bay) Device
https://support-en.wd.com/app/answers/detail/a_id/24022

In certain rare cases an ISP router can conflict with the My Cloud. The workaround is to connect the My Cloud to a network switch, then connect that network switch to the ISP router.

My Cloud is not recognized when connected to AT&T Uverse, Pace, Arris, Ubee or Sonic Gateway Routers
https://support-en.wd.com/app/answers/detail/a_id/3637

@Bennor Thank you very much. The 4 second reset did the trick. I had a hunch I needed to reset the IP Address, but could not confirm if the 4 second reset would reset the IP.