Cannot connect to MAC after update to 10.6.6

Since I have upgraded my MacOS to 10.6.6 I cannot connect.  The WD device see’s my Mac but it cannot connect.  Any suggestions?

I am in the same boat …

It worked really well (on Firmware 1.03.29_B) on my 24" iMac.

My 24"  iMac bit the dust and I replaced it with a brand new 27" iMac. After using the exact same settings on the new iMac, I can not get the WDTV to see the shared folders? I can easily get on my wireless Airport network, and the WDTV lists the new iMac under Network shares just like before, however, when I try to log in I keep getting the same message “This  network share can not be accessed”. I have tried dozens of the recommendations on this and other forums to no avail. I want my wireless streaming of shared folders/files back! Wondering if SMB/Samba has changed on the newer iMac?? Any ideas / help would be appreciated.

Some of the many things I have tried…

Set up the shares just like on my previous iMac.

(Checked file sharing, checked user, entered user password, add folders to share window)

(Firewall off)

Tried checking both guest login & share boxes

Tried using guest account

Tried using “new” accounts & different passwords

Tried apply permissions (read & write) to shared folders (and enclosed files)

All variations of AFP, FTP, and SMB (just used SMB on previous iMac)

Tried reset of WDTV (reset switch on side, un-plugged for 30 min.+, reset to factory defaults) … multiple times.

Tried clearing network shares login … multiple times

and the list goes on and on with the same result … “This network share can not be accessed”

Here is a kicker … I purchased the WDTV Live Hub (thinking I had a bad WDTV Live Plus), and had the same issue.

The WDTV Hub promptly went back to the store.I am beginning to think that there is something “new” in the iMAC OS 10.6.6 / SMB or Samba that is not jiving with the WDTV?


How are you trying to connect? Wirelessly or hard wired through the Air Port.

My WDTV Live Plus is connecting to the internet fine via the Airport Express. Just can’t see my shared folders / files (Wireless). I am using a D-Link USB Wireless Dongle on the WDTV.

I’m having the same issues, please help.

i’ve tried both the WD TV Live Plus as well as the WD TV Media Hub. Everything was working fine until my hard drive died. When i go the new drive installed into my imac i upgraded to 10.6.6 and now i can’t access my shared files. When i first turned on the Media Hub the files showed up but when i tried to play them i only got a black screen and then the Hub crashed. When i reconnected and tried again it would no longer connect. I checked the network settings and i can no longer get an ip address. i am connected to my WD player through ethernet (wired) via powerline networking.

on a side note i’ve also tried the asus o!play with no success either which leads me to believe that the problem lies in either the network or my mac settings and since the network hasn’t changed the problem must be in the mac settings. if anyone can post a detailed discription on how to configure the network settings and the sharing preferences that would be great.

I’ve done some searching about this, and it seems 10.6.x has broken Samba somehow. The general fix seems to be to edit (as root) the /etc/smb.conf file (although this refers to 10.6.3, people are still reporting problems with smb shares in 10.6.6).

Add the line 

unix extensions = no

to the [global] section (at the top). 

Make a backup of smb.conf before you edit it. You can’t hurt anything anyway but make a backup.

I don’t actually know that this will fix the problem with your  WD, but it can’t hurt to try. I’m still using 10.5.8, and everything works fine here. Here’s an explanatory link:

Apple are making noises about having this fixed in 10.6.7.

Warren, Thanks for the information! I will definitely give it a try tonight and let this post know if it works out!

I tried the edit to smb.conf (unix extensions = no) … no change, I still get “This network share can not be accessed”.

Out of desperation, I tried the homebrew firmware WDLXTV. It runs faster than the stock WD firmware, looks nice, and has some pretty cool features, however, it did not fix the connection to network shares. I noticed an smb.conf file that came with the WDLXTV firmware, so I replaced the iMac smb.conf with the one that came with WDLXTV. I noticed that under network shares I no longer saw my iMac hostname, instead it came up with XXXHOSTNAMEXXX instead?? I tried to connect anyhow and still got the message “This network share can not be accessed”. At this point I decided to replace the smb.conf back to the original iMac smb.conf file … UH-OH, where did it go?? I created a backup called smb.conf-backup, but it is nowhere to be found now?? I searched forever, and it does not exist?? Does anyone have a default smb.conf file for OS X 10.6.6 that they can send me??

Here, I’m running 10.6.6 on my Hackintosh:

Thank You PixelPower, much appreciated. Now If I could only get the darn network share to work!

As an experiment I wonder if you could access the network share on your iMac if you connected your WD TV Live Plus directly to your iMac via ethernet.

Another experiment you could try, if feasible, is connect the Airport Express directly to the WD TV with an ethernet cable and see if this changes anything.

I have thought about a direct cable connect, however, the main reason I purchased the WDTV was to take advantage of the wireless option (which worked wonderfully on my previous iMac). My one and only TV (Flatscreen) is two rooms removed from my iMac, and very securely mounted to the wall. I will probably haul the iMac into the other room and connect it to the WDTV via ethernet cable, just to see if network shares work via wired!

As for the Airport Express, unfortunately, it only has 1 ethernet port, and that is used by the incoming network cable (from my cable modem). I am also tempted to buy the Airport Extreme, which has “additional” ethernet ports.

I see over 700 views of this thread. Tells me there are a few out there with a similar problem!? Anyone have any breakthrus yet? My WDTV Plus has become just a media player. I shuttle files from the mac to a thumb drive, then play them on the WDTV. Seems to play almost every format that I throw at it, however, still not why I purchased the WDTV (purchased to stream video from my mac to my TV).

Just purchased a new Airport Extreme. NO CHANGE! Still get the dreaded “This network share can not be accessed” message. (Both Wired and Wireless)