Cannot connect over WiFi to My Cloud - Mac Laptop - El Capitan

I know there are several topics related to this, but I still can’t get a working solution for this issue.

About a month ago, my MBP stopped being able to access the My Cloud over WiFi. It worked perfectly before; I had sidebar shortcuts that would jump on immediately. Now I get the dreaded:

"There was a problem connection to the server “Servername”.
The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again."

All other devices are able to jump on - my wife’s laptop (same as mine, with an older OS) my Mac Mini (hardwired, so that explains that) and my phone is able to access the Plex server on the My Cloud no problem. So what’s with my laptop?

If I hardwire the laptop, it jumps on the drive (as a guest for some reason) and I’m able to access everything. Wirelessly, it just won’t happen. Command + K or Finder > Go > Connect to Server don’t work either.

ANY help is appreciated. I’m using my My Cloud as a small server for my home and it’s important that I can access things on in or put things on it since I work from home.

Thanks –

Mike

MacBook Pro (13-inch, Mid 2012)
Processor 2.5 GHz Intel Core i5
OSX El Capitan 10.11.5

Since you can access the MyCloud via Ethernet, I suggest the problem is with your Macbook or router.

The fact that your wife’s identical hardware but earlier OS works probably rules out the router, and points to your OS as the problem, or something very specific to your macbook.

Have you read the long thread on El Capitan problems?

I’m not sure if I have. I went through about 7-8 threads trying solutions.

If you have a link, that’d be great, but I’ll try and track it down.

There are a lot of threads…

https://community.wd.com/search?q=El%20capitan%20category:105%20order:latest

…but the one I was thinking of is:

I solved it with the help from a friend.

I simply created a new network location with default settings in System Pref.

Jumped right on.

Thanks for your help cpt_paranoia!

Mike