Cannot connect MyBookWorldEdition to Win7

Hi, I have a very basic problem. I have a MB WE 2TB device that I used to connect to an XP machine. Now I have a new Win7 laptop on a new wireless network. I have downloaded MioNet for Win7 64-bit, and tried to get connected to the NAS drive. The Mionet client registers the new PC name to the server, and asks me if I have previously installed Mionet on this computer. I reply NO and it searches for the drive, but finds nothing ‘no storage devices found in the local network’. The network-attached printer works, the internet is accessible, I even disconnected the firewall. I can’t use the device. I have tried re-booting the PC, the MBW. Nothing works. Help! Please!

I found the Mionet scrubber and started again, also reset the NAS. Now I got mionet to install but when it starts after rebooting the computer I get a message saying that a necessary driver cannot be used unless I reboot. I reboot… and get the same. The drive is not visible on the home network in Windows 7… and now I have an error message on startup about some error at some address.

How can an off-the-shelf device connected to an off-the-shelf PC with standard windows 7 be so very hard to install? I have tried turning off my ESET security and turning off file sharing in Windows - nothing works. 

I am a British expat living in Maputo, Mozambique, in Africa, and I don’t have any recourse to IT experts to sort me out. Is there some kind of offical WD help? I invested 500usd in this device and never managed to make it function… I worked 9 years in IBM, it seems hard to believe I could be so stupid as to break it…

Check if the link below works.

Are you doing a remote connection or just LAN ?

If it’s the latter there’s no need to use Mionet. Just map the drive on the computer.

If you are connecting via Mionet for remote, you can use Alucard’s option to update Mionet.