Cannot connect my cloud

had to sign up just to add that i can not access my cloud device for over 2 weeks now

can sign in on my network but as soon as i leave home or switch to another network or 3g/4g i cannot connect

i have gone into settings and cloud access turned it off and on done auto manual and xp, checked my router and the my cloud is still in dmz mode (so no port forwarding needed) and no updates for the router had been applyed 

in cloud access it says

Connection Status Connecting 

Trying to establish a remote access connection…

thats all it does 

have i missed something???

is there a status page for the wd my cloud servers it connect to 


“…can not access my cloud device for over 2 weeks now…”

Sorry, but …how did you ever noticed that a MyCloud is still connected?



I use it a lot while at work I.e not on my home WiFi so about 2 weeks ago it started saying it cannot connect

So tried to remove device and add it with activation code and then tried signing in with my user and password and failed

In settings in general under cloud access in connection status will show u if you connected to the relay

Which as I am writing this has now changed from trying to connected
Lol which is funny as the only thing I have done today was open the setting page to type this msg and it has now connected