Cannot AFP to 1TB MBWE, SMB works


I did a search and this is the closest I found to someone having the same problem, though I am not sure it is exact as it concerns the 4TB edition, not the 1TB edition I have.

My setup: A MacBook Pro connecting wirelessly to a Belkin N+ Access Point that has a wired connection to my WD 1TB MyBook World Edition.  I purchased the MBWE about 7 or 8 months ago and it had been working great.  TimeMachine always backed up and I could always mount the Public or Download folder from the left pane of the Mac Finder with a click.  I loved it. 

About 2 months ago I started getting intermittent failures from TimeMachine saying it could not complete the backup.  Since I was not changing that much data and I was traveling a lot for work I didn’t take the time to really see what was happening and upon checking my TimeMachine backups it was working often enough that I was OK.  I also keep a second USB drive handy with a duplicate of media and such so losing the 1TB MBWE wasn’t going to kill me.

Fast forward to today and I still get the intermittent failures from TimeMachine.  In addition I tried to click MyBookWorld in the left Finder pane and it just sits there saying “connecting”.  It never stops and it never actually connects.  If I use the  Go->Connect Server… route I have different outcomes. 

If I afp://mybookworld.local/ it will pop up and ask for username and pw.  If I use admin or the user I created to match my MacBookPro account I get the same result.  It will then ask me which volume I want to mount and when I choose Public it just sits there forever saying “connecting” and never does.  Similar to clicking it in the Finder pane.

If I smb://mybookworld.local/ it will pop up and ask for username and pw.  If I use admin or the user I created it accepts.  It will then ask me which volume I want to mount.  When I choose Public, it mounts successfully!  OK, so now when I look in my Finder, the left pane now lists mybookworld.local (mounted via smb), MyBookWorld (which doesn’t really work), and MyBookWorld-Backup (which I never touch).

It seems to me the problem is specific to afp access and I have not changed anything on the MBWE settings.  I can access the MBWE configuration via Firefox or Safari.  When I check the settings afp is still enabled as well as nfs, etc.  I don’t use Mionet, but that is at its defaults as is everything else with the exception of the user I created to match my MacBook Pro user account.

The drive is not full (far from it).  I have used about 300 GB of the total capacity.

Any ideas out there as to why a) TimeMachine all of a sudden is intermittent and b) afp access does not work?



Dear all.

I have the same problem with my mac mini (10.6.4)  - I dont know what happened in between. But I cannot logon via afp to use the use nas e.g. for time machine. It worked fine for me over 10 month. SMB/FTP works …

Could you please help.

My book word 1.5 tb

<Best regards, Jens.

  Meh… I’m not entirely sure about this mind you, but it strikes me that the problem is likely interrelated… I’m not entirely sure what protocol TimeMachine uses to communicate for network backups though, so… Maybe we should establish that.

  Also, meantime, a silly question / suggestion: Have you tried disabling then re-enabling the AFP services?

  Wirth a try…? :slight_smile:

I’ve had this problem for a very long time now but I just found out a way to fix it. The thread that helped me work out the problem is here:

It appears that the file system contains special files and folders called  .AppleDB .TemporaryItems .DS_Store .AppleDesktop. All you need to do is mount the drive using Samba, enter all the folders that you need to share and delete the above mentioned folders. This trick worked for me.

PS. There were some weird looking files as well, which mac os x saw as binary files, with filenames terminated by a ~ and made up of random characters. I’ve also deleted those.

Good luck and if it works for you, make sure you link back to this post as I’ve seen it’s a common problem among mac os x users using WD MyBook.

1 Like

Qinty!  Thanks for the info.  Following your steps and that link brought everything back to normal.  One thing I would mention is that to individually mount certain folders through the “Go->Connect to Server” route only requires that you delete the mentioned hidden folders from the folder you wish to mount via AFP.  If you want to be able to click on MyBookWorld from the left pane of the finder and have it work, you need to do this to EVERY folder you could possibly mount.

Thanks again!


Found this worked for me: 

"The problem seems to be solved by logging into my bookword via Bonjour going to 

Advanced Mode>Network>Services

deselect AFP service enabled checkbox and clicking submit the selecting AFP enabled checkbox and clicking submit.

It then seems to work as it did before 10.6.4 for at least 24 hours. "

Found here: