Cannot access WD7500bpkt


I recently disconnected the WD7500bpkt from my broken Windows Dell laptop and bought a WD casing to connect the drive to my Windows 7 desktop using USB cable.

For awhile it was working very well. I was able to access all files.

One day, I tried to access the WD7500bpkt with my Mac Book Pro. I should have known it won’t work since it’s a different OS or Mac. A prompt appeared asking me if I wanted to reformat or partition drive. I ignored it and disconnected the USB cable.

Didn’t think anything of it until a few days ago when I tried to access the WD7500bpkt with my Windows 7 desktop using USB cable. As usual, the desktop auto-installed the drivers so in order to read the WD7500bpkt drive. However, it took forever to read the drive. After waiting patiently for a long time I was not able to access any of data or content in the drive.

Can somebody explain what’s going on? Is it possible that the Mac encounter may have messed up or corrupted the system drivers?

I like to get it checked or repaired but not sure where to begin. If I were to fill out an RMA, I know it would involve a replacement which is fine. However, I’m more concerned about backing up my data which I am unable to do so since I cannot access the files.

Please advise.

Hello, Although WD hard drives should work properly in external enclosures, WD is unable to provide support for drives in this configuration beyond suggested jumper settings and warranty replacement. Any additional questions about using a WD hard drive in an external enclosure should be directed to the company that manufactured the enclosure.

I recommend that you try connecting the drive directly to the motherboard and see if you can get your data.