Cannot access WD MyCLoud through File Explorer anymore

I use to be able to access my cloud through File Explorer on my PC which has windows 7. This lasted for a couple week after I set it up and everything worked as expected. now i am not able to see my cloud on File explorer and have to go the the website and login even if im connected to my home network. 

Does anyone have experice with this problem and is able to help me find a solution? 

reset you device from the button on the back. Keep the button pressed for a few seconds. There is another kind of reset, by unplugging the power cord and the network cable, press the reset button and plugin the power cable. Hold for 40 seconds.

i would recomand that you save your setting before you do this

PS: this will not erase the data from the disks


have you tried to use WD Discovery app (installing it on your pc) ?

It will do the job for you, configuring the links (Public, Private folder) on the PC.

You will find it on WD support site.

Hi (new user here), did you get your issue solved? I’m on win8.1 and had a similar issue.

My device name would not show up in the network panel of win explorer (yet on my brother’s computer it did show).

I had to type in “\[device name]” into the file explorer window.

But now I fixed my issue by turning on network discovery for “public” and guest devices (it was already on for “private” networks).

Not sure how you do it in win7. But maybe try a google search to enable network discovery for “public” and guest devices. Then my device showed in the network panel.

Also the mapping shares (using the WD app) did work, but not perfect.

It created folders going to the LAN IP of my device, and named after each shared folder: “Public (\ (F: )” (It turns each folder into a drive mounted(?) by windows, and shown in the “Network locations”).

But when I rebooted the device, its IP on the network changed ( to So now I have old folders in my list that do not refresh.

Hello, suddenly I’m not able to access my attached WDMyCloud drive. I have a MyBook Live, a MyBookLive Duo, a MyCloud and the WDMyCloud all attached to my network on my Windows 10 PC. All of them have worked perfectly, allowing me to move content onto all of them. For some reason now whenever I try & access the WDMyCloud, I get the “\WDMYCLOUD is not accessible. You might not have permission to use this network…The remote procedure call failed and did not execute message”. I have not altered any of the setting for any of the drives or network. All of the other drives work as before, I’ve crawled thru all the settings via Dashboard to try & find any clue. I have gone into Advanced Setting under Network adapter, an all looks correct. Since I use this to store my music files for my home playback, this is driving me nuts, can anyone suggest what to try or look for?