Cannot access Twonky media server on MyBookWorld - "Refused to Connect" (Please help!)

Hi all,

Looking for some help please.

Basically, I’m unable to access the Media Server (Twonky) . I’m on the latest f/w on the NAS and I think from memory the media server is Twonky v5.

Everything was working fine about 12 months ago - but we moved house and I’ve only just recently plugged it in. The NAS is working fine - I can access shares but the Twonky clearly isn’t happy.

When trying to connect to I get the error below.

I’m on Windows 10. Using Chrome and IE.
WD MBW firmware: 01.02.14

I have trawled through various support sites but haven’t found anything that helps. I have Putty installed (although a total newbie with it).

Any help would be much appreciated!


Have you tried resetting the unit? (Make sure that you data is backed up before you do any procedures)

Was the unit being used with a static ip?


Thanks for the suggestion.

I haven’t tried resetting the unit because I have too much data on their to copy off anywhere else.

I was hoping I could use SSH in some way to reinstall Twonky - but I am not sure.

do you know?


No, I haven’t use SSH to modify any of my units as this will void the warranty on the WD Products.