Cannot access to my data (public folders) using my McBook Air

Hi everybody,

I’m seeking for information.

I bought a My Passport Wireless one week ago. Everything is fine when using my I-Pad : I can connect using wifi and access to my data using the my cloud app.

However, I cannot access to my data using my McBook Air :frowning: My Mac is connected to the wifi of MPW, I can go on the dashbord using WD Quick view, I can connect my MPW on my Box, but I can never access to my data stored on it.

Can someone help me ?

The support guys of WD do not answer to me :frowning:




Does resetting the unit makes any changes? What about connecting the drive locally to the Mac for testing?

What do you mean in detail by “I cannot access to my data”? Your passport device is listed in the left pane of finder window? You can’t connect as guest to this device? Sometimes it’s faster using the menu “Go to” => “Connect to server …” and enter “smb://” (depending on your setup smb://MyPassport/Storage" may also work).


Thanks for your Answer. I tried several times to reset the unit, but it doesn’t make any change !

I am not sure to anderstand when you propose to connect the drive locally. I assume you are refering to usb connection. I tried and everything is fine that way.

As I can access to my data with my I-Pad, I am wondering if the problem is not coming from my Mc-Book Air. What do you think ?

Envoyé de mon iPad

Thanks for your Answer.

I mean exactly what you say : the passport is listed to the left pane of finder window, but I cannot connect to it as guest to this device. I have already tried to connect to it using the procedure you mentionned (smb://…) but the connection failed too.

Could the problem come from my computer?

Envoyé de mon iPad

Did you connect the MPW to the home network? Maybe it got a new address from your router by DHCP, hence the original one won’t work any longer?