Cannot access ShareSpace drive from Internet


#1

I’ve trying to connect to my ShareSpace drive through http and ftp, but nothing works.  I can connect from my LAN, but when I try from WAN (both via Firefox and via IE), I get an error message.  I’ve tried using different ports for port forwarding, but itdidn’t help.  I’ve also turned off the firewall. Any other idea?

Thanks 


#2

Sounds like your ISP is blocking port 20/21 and 80. Is there anyway to confirm?


#3

I also tried other ports, e.g. 8000, 8001 - didn’t work either.  I assume it’s something else.


#4

can u please connect to your ftp server from your LAN, and get the welcome message? I have a feeling it is using passive mode. As you might have already known, passive mode involves some other random ports. I am looking for something like this:

Command:    PASV
Response:    227 Entering Passive Mode (192,168,1,4,19,164)


#5

It would be better if you could also get the welcome message when connecting from the internet.


#6

Here is the welcome message when connecting from my LAN:

Status:    Connecting to 192.168.1.9:21…
Status:    Connection established, waiting for welcome message…
Response:    220 vsFTPd 2.0.4+ (ext.3) ready…
Command:    USER admin
Response:    331 Please specify the password.
Command:    PASS *****
Response:    230 Login successful.
Command:    SYST
Response:    215 UNIX Type: L8
Command:    FEAT
Response:    211-Features:
Response:     EPRT
Response:     EPSV
Response:     MDTM
Response:     PASV
Response:     UTF8
Response:     REST STREAM
Response:     SIZE
Response:     TVFS
Response:    211 End
Command:    OPTS UTF8 ON
Response:    200 UTF8 option is On.
Status:    Connected
Status:    Retrieving directory listing…
Command:    PWD
Response:    257 “/”
Command:    TYPE I
Response:    200 Switching to Binary mode.
Command:    PASV
Response:    227 Entering Passive Mode (192,168,1,9,19,142)
Command:    LIST
Response:    150 Here comes the directory listing.
Response:    226 Directory send OK.
Status:    Directory listing successful


#7

As expected, it is using passive mode:

Command:    PASV
Response:    227 Entering Passive Mode (192,168,1,9,19,142)

The response shows that, for this session, the server is listening on port (19*256)+142 = 5006 for data chanel. If this port is not properly configured on your router/proxy, you will not be able to make connection from outside.

My suggestions is to open a range of ports (5000 - 6000 maybe?).

You can find more information here: http://slacksite.com/other/ftp.html