Cannot access shares over WebDav

Hello,

I have a fresh and untouched firmware installation and two shares. Now I want to access them via WebDav in the intranet, e.g. point firefox to

http://192.168.2.105/

Where is the name of an existing share on the device (e.g. Public). I can access them via samba and netatalk, so they are obviously registered.

In the browser I get an htaccess dialog prompting me for the username and password, I type in valid credentials. But the login does not work, the htaccess dialog keeps to prompting over and over and I don’t get access to the shares. Same story when I try to point Finder to the webdav address (Go to -> connect to server)

What is wrong here? Is his a(nother) bug in the firmware? I’d expect this just to work, especially since I did really not touch anything in the firmware this time.

I seems that the credentials are not synchronized with htaccess…

Thanks in advance

plasmapelz wrote:

What is wrong here? Is his a(nother) bug in the firmware? I’d expect this just to work, especially since I did really not touch anything in the firmware this time.

No, it’s not a bug in the firmware, as WebDAV isn’t a supported access method.

WebDAV is only present for use with Mobile / Cloud access, and who knows what kind of security backend they’re expecting.

Well, I don’t want to register an account with WD to access my device.

As I see from the Apache config file, WebDav is supported and enabled. Probably it is the method to access your shares through this wd live account, but I guess that the credentials are not put in place on the device until you register this wd live account.
It would be simple to do this manually… and for WD it would be simple to provide a button in the dashboard to do it without wd live account. The trouble is that - as always - some black magic introduced by WD will prevent it from working properly, or something else will be destroyed when I manually change the settings. I have had so many bad experiences with such manual config file changes in the last year that I am inclined to leave it that way.

Nevermind, I am going to buy a qnap anyway.