Cannot access secured folders on MyBook WE II

I have MyBook World Edition II (White Light) set up as a NAS and tried to use the WD Anywhere Backup.  Using the defaults it put the backup for my Vista machine in the public folder.  Not secure at all.  I want the individual PCs to have their own secure folders for backup and various work that only the user and admin can access.  I have each of the folders set up as a mapped drive.

I’ve created secure folders with full privileges granted to the user and admin.  However, when trying to access these folders from the main PC (whether accessing via Windows Explorer or via the WD Anywhere Backup) I get the following error message after it asks me to login:

"MYBOOK-WORK\Foldername is not accessible.  You might not have permission to use this network resource.  Contact the administrator of this server to find out if you have access permissions.

Multiple connections to a server or shared resources by the same user, using more than one user name, are not allowed.  Disconnect all previous connections to the server or shared resource and try again."  This is a Windows message but not sure why it’s active in my case or how to get rid of it.

I’ve tried logging off and on as well as restarting the PC with the same results.  I’ve tried the user names and passwords for every different user I’ve authorized.  No luck.

So, to recap:

  • I need to have my automated backups placed in a secure folder accessible only to the user (and admin) rather than the public folder.

  • The MyBook is currently preventing me from accessing any secured folder with the Windows shared resources error.

Any help would be appreciated.  Having a backup that includes financial data personal information etc in the public folder and accessible by anyone on the network is not intelligent.


I am having the same problem.  I have a few different users with different privileges and all the folders that are not “public (full access)” I can not access them through the LAN.  It asks me for login info and it doesn’t matter what user name and password combo I use, it gives me the same error message!!!

What is the point of have user accounts and privileges if you  “ADMIN”  can’t gain access to the folder after the changes???

It’s a Windows problem. It connects to the NAS as guest first. Once it does that, it won’t let you connect as another user. There are a couple of possible fixes, though.

Connect as the user you want first.

  1. First, get rid of the existing connection. Go to a command prompt and type net use to get a list of connections

  2. Find the connections for your NAS.  For each one type Net use /delete

  3. IT should say that it was deleted succssfully

  4. Map a drive to the share you want. Start by going to the network connections

  5. Go to tools -> map network drive

  6. Pick a letter, type in the path to the share, and click Connect using a different user name

  7. Type in the user name and password, then click OK

  8. Make sure “reconnect on login” is enabled, then click OK

Match user names

A simpler way is to create a user and password on the NAS that matches your Windows user name and password. This may not work for some user names, since Windows allows characters (such as periods) that the NAS doesn’t. If you can do this, though, it will be a lot simpler and more reliable.


Thanks for the information.  This is very helpful.   I could use more help / info on matching the user name / password to the Windows login.  This is my preferred approach but I’ve tried that.  Simple one-word user name with simple one-word login to Windows (e.g. username - John, password - Dallas).  Created a NAS folder with folder name and login with name  and password same as the Windows login.  Still can’t access that folder.

Thanks again,


Finally got mine working using a tip from :

use the device’s IP adress rather than the actual MyBookWorld name: