Cannot access mybooklive/ui anymore

I can’t open mybooklive/ui with the browser anymore. The Twonkyserver config on port 9000, SSH and accessing the shares is still working. It is not a router/configuration problem I think. I already tried this with mybooklive connected to my laptop via a direct LAN connection. Same result. Also a reboot didn’t heal this.

Somewhere in this forum I read manually restarting the apache server could fix this. So I tried running “/etc/init.d/apache2 restart” which gives me this error message:

Restarting web server: apache2Syntax error on line 82 of /etc/apache2/sites-enabled/000-wdnas:
Invalid command ‘php_value’, perhaps misspelled or defined by a module not included in the server configuration

That mentioned line contains this:

<Directory “/var/www/UI”>
RewriteEngine on
RewriteBase /UI/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^$ app/webroot/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) app/webroot/$1 [L]
php_value memory_limit 1G

I guess “php_value memory_limit 1G” is wrong so I commented it out and now apache starts but accessing /UI is still not working. If I access that URL a PHP-file gets downloaded. This PHP file seems to be the index.php from /var/www/UI/

Is there any way I can fix the UI? I don’t know how this could be broken. After the last firmware update a few month ago the UI was working. Then I didn’t use it for a while and now I realized it isn’t working anymore.

Frustrating, so much time wasted in finding a solution. Can someone help me?

Hi there,

This type of modification is not supported, I have not tried this, lets see if another user can help you out and share some ideas and tips on this matter. 

I had the same problem MyBookLive showed on my network but I couldn’t access it through the browser (FF). Tried a solo restart of the HDD, nothing.

Just finished a complete restart of my whole network: modem, router, PC and WD HDD. Started with the modem, of course, after leaving it unplugged for at least 1 minute. Once it showed active > the router…once active > then PC then HDD last. 

Don’t know why, but this worked and everything looks normal.

Hope this helps \m/

Paul

ArMark, what do you mean by “this type of modification”? I’m not aware that I’ve done any modification besides the firmware update and my recent tries to fix the UI. Is it possible to get an original copy of the files which I have mentioned in my post?

did you upgrade or modify your php? php_value is available from a module, your 000-wdnas looks correct.  After doing a horrible apt-get update and fixing circular dependencies and gpg keys and so forth, i was getting a blank page. After looking at /var/log/apache2/error.log it turned out I had to reinstall php5-curl.

I can’t find any problems in the error.log, last entries are:

[Wed Dec 03 19:15:45 2014] [warn] RSA server certificate wildcard CommonName (CN) `*.device19169.wd2go.com' does NOT match server name!?
[Wed Dec 03 19:15:45 2014] [notice] Apache/2.2.9 (Debian) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8m configured -- resuming normal operations

Did you undo your changes to 000-wdnas because they are originally correct?

Please paste the output of /etc/apache2/mods-enabled/php5.conf

and

/etc/apache2/mods-enabled/php5.load

and then verify /usr/lib/apache2/modules/libphp5.so exists.

then paste the output of php -v

php_value is provided by mod_php itself, if it doesn’t work php isn’t being loaded, website won’t work period. We are verifying that its being loaded.

  • /etc/apache2/mods-enabled/php5.conf doesn’t exist

  • /etc/apache2/mods-enabled/php5.load doesn’t exist

  • /usr/lib/apache2/modules/libphp5.so does exist

  • outupt of php -v:

    MyBookLive:~# php -v
    PHP Deprecated: Comments starting with ‘#’ are deprecated in /etc/php5/cli/conf.d/pdo.ini on line 1 in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php5/20100525+lfs/pdo.so’ - /usr/lib/php5/20100525+lfs/pdo.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP 5.4.4-14+deb7u9 (cli) (built: Apr 18 2014 21:40:35)
    Copyright © 1997-2012 The PHP Group
    Zend Engine v2.4.0, Copyright © 1998-2012 Zend Technologies

 Seems like I should also reinstall php like you mentioned before? How should I do this? I tried apt-get install php5-curl and get:

Reading package lists... Done
Building dependency tree
Reading state information... Done
php5-curl is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  libapache2-mod-php5: Depends: php5-common (= 5.4.4-14+deb7u9) but 5.2.6.dfsg.1-1+lenny9 is to be installed
  php5: Depends: php5-common (>= 5.4.4-14+deb7u9) but 5.2.6.dfsg.1-1+lenny9 is to be installed
  php5-cli: Depends: php5-common (= 5.4.4-14+deb7u9) but 5.2.6.dfsg.1-1+lenny9 is to be installed
  php5-curl: Depends: php5-common (= 5.4.4-14+deb7u9) but 5.2.6.dfsg.1-1+lenny9 is to be installed
  php5-sqlite: Depends: php5-common (= 5.4.4-14+deb7u9) but 5.2.6.dfsg.1-1+lenny9 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Finally I solved this by just re-installing the firmware package via shell. That was an easy fix. Hey WD “support” list that in your FAQ!

Glad you solved it.  Yes, for basically any problem with the MBL, the first line of action should be to reinstall the firmware.  As you figured out, it can be done from the Dashboard or from SSH.  As long as you have one of those active, you are home free. If you don’t have either avaliable, then you have to do the Debrick method - which does not harm your data, just reinstalls the firmware.