Cannot access MyBook World over AFP


#1

Hi all!

Here’s my story:

Yesterday I had a power outage.

Today I try to connect to my MyBook on my mac as usual. No luck. The Mac says connection fails.

Tried to reboot everything: Mac, MyBook, Router. Nothing worked

I looked around on the forums and found that others also have trouble with AFP…

I can access the shares over SMB and FTP but not AFP (and of course Time Machine doesn’t work). Some forums posts advised to delete the Mac OS specific files on the MyBook (.AppleDB .TemporaryItems .DS_Store .AppleDesktop). Still no luck, even after a reboot.

I tried to disable and re-enable AFP in the MyBook Network config panel. 

But it refuses to enable AFP again. Error says ‘Failed to update services’.

Can you help?

Many thanks!!!


#2

Is it possible to post a screen shot of that issue?


#3

Sure it’s possible…!

Here’s the connection error when I click on the drive’s icon (Volumen). If I click ‘connect as…’ a dialog box appears, it says the drive is unavailable or the IP address is wrong.

You can see there that I can connect to it using SMB.

connection error.png

And here’s what happens when I try to turn back AFP on in the MyBook LAN Services settings. Computer says no :smiley:

afp error.png


#4

I have the exact same issue. Everything was fine before the firmware upgrade. :cry:

Any help would be great !


#5

Oh well. Seems there is no quick and easy solution.

I backed up most of my files to a hard drive I had laying around, gave up my Time Machine backups and did a factory restore. It worked.

Now I’m copying everything back.

Good luck ps3wd!