Cannot access MyBook Essential on Vista


#1

Hi,

I have recently reformatted with Vista and I can no longer access my MyBook Essential (1TB).  It tells me I need to format the disk, but I don’t want to do that because I need the files on it.  It was working before the format, so I am wondering what I need to do.  Is there something I need installed on my local disk?

I have downloaded the software for my hard drive from the website.  When I run “WDSetup.exe”, I select “Copy Application Software” and click Start, but it says “unable to launch installer”.

Thanks for your help.


#2

Hi what Operating System did you have prior to Vista was it XP? Also before running WDsetup.exe does vista detect your hard drive? Vista is compliant with plug and play and it should detect it. Please let us know what hard drive your using,  model and if it is the new NTFS file format or the older FAT32 format.


#3

The model is WD10000H1U-00 (1TB) and it seems to be NFTS format.  How can I check?

I was using Vista last time also and the hard drive worked fine.

Vista seems to detect it, under Device Manager it shows up as “WD 10EADS External USB Device”.

When I go to Properties and then Volumes and Populate the list, it shows up the following information:

Disk: Disk 1

Type: Basic

Status: Online

Partition Style: Master Boot Record (MBR)

Capacity: 953869 MB

Unallocated Space: 2MB

Reserved Space: 0MB

My driver version is 6.0.6000.16386 from 21/06/2006


#4

Okay, I’ve worked it out.  I didn’t have the latest service pack installed.


#5

I’m having the same problem. What service pack were you missing?