Cannot access My Passport WDBY8L0020BBK-01

Hi I have a My Passport WDBY8L0020BBK-01 USB 3.0 drive. When I plug it in I cannot access the disk and the system hangs.

I have also tried with a different USB cable.

I tried in Linux and it gives me this text in the log:

[1623.303019] usb 1-1: new high-speed USB device number 3 using ehci-pci
[1623.418146] usb 1-1: New USB device found, idVendor=1058, idProduct=0748
[1623.418151] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=5
[1623.418154] usb 1-1: Product: My Passport 0748
[1623.418157] usb 1-1: Manufacturer: Western Digital
[1623.418160] usb 1-1: SerialNumber: < serial removed
[1623.418683] usb-storage 1-1:1.0: USB Mass Storage device detected
[1623.418758] scsi8 : usb-storage 1-1:1.0
[1624.419583] scsi 8:0:0:0: Direct-Access     WD       My Passport 0748 1019 PQ: 0 ANSI: 6
[1624.419947] scsi 8:0:0:1: Enclosure         WD       SES Device       1019 PQ: 0 ANSI: 6
[1624.420221] sd 8:0:0:0: Attached scsi generic sg1 type 0
[1624.420378] scsi 8:0:0:1: Attached scsi generic sg2 type 13
[1624.424685] sd 8:0:0:0: [sda] Spinning up disk…
[1632.467207] scsi 8:0:0:1: Failed to get diagnostic page 0x8000002
[1632.467213] scsi 8:0:0:1: Failed to bind enclosure -19
[1632.467231] ses 8:0:0:1: Attached Enclosure device
[1625.426022] …not responding…
[1736.897437] sd 8:0:0:0: [sda] READ CAPACITY failed
[1736.897441] sd 8:0:0:0: [sda]
[1736.897444] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[1736.897446] sd 8:0:0:0: [sda]
[1736.897448] Sense Key : Not Ready [current]
[1736.897452] sd 8:0:0:0: [sda]
[1736.897454] Add. Sense: Logical unit is in process of becoming ready
[1738.917314] sd 8:0:0:0: [sda] Test WP failed, assume Write Enabled
[1740.937250] sd 8:0:0:0: [sda] Asking for cache data failed
[1740.937253] sd 8:0:0:0: [sda] Assuming drive cache: write through
[1740.943251] sd 8:0:0:0: [sda] Spinning up disk…
[1743.959017] …not responding…

Is there any way to access the data?

Also can someone fix the forum bug when using IE8 as it does not let me type spaces in this message body without copy/paste, which is quite inconvenient.


The WD portable drive are not fully supported on linux OS due to the drivers issue.

Are you able to test the drive on a Windows computer and check how is the drive showing under disk management?

See if the following link helps.

When the disk is plugged in to a Windows system it hangs and the disk does not appear within Disk Management