Cannot access My Passport Ultra 1TB

Windows 7 Professional 64-bit, completely up to date.  All USB ports are USB 2.

While transferring JPEG’s to the Passport yesterday, using Windows Copy/Paste, data transfer slowed to nearly a stop.  Cancelled the transfer and now cannot access the drive.

Drive appears as drive F: in My Computer (which is correct drive letter), but cannot be accessed.  Drive appears in Device Manager/Disk Drives.  When drive is connected, NO drives, neither internal or external, will appear in Disk Managment in the Computer Managment Console snap-in.  When drive is not connected, Disk Managment operates correctly.

Cannot run CHKDSK on the Passport.  Enter the command and nothing happens.

Have used different USB cables with no difference.  Have used all available USB ports with no difference.  Have used two different computers - desktop and laptop - with no difference.

Have freshly installed lastest drivers.

When plugging device into already running computer, get the Windows tone recgnizing a new USB device.  When trying to disconnect/stop/eject the Passport, it will not complete that operation and the computer must be shut down to safely disconnect.  Shutdown takes nearly 5 minutes when the Passport is connected (not ejected).

Western Digital will RMA the drive, but I need to get to the files.

Have not tried software recovery tools.  Not sure how I can run software recovery on a drive I cannot access.

Help and suggestions would be HUGELY appreciated.


Have you tried testing the unit using the WD DLG Tool?

How to test a drive for problems using Data Lifeguard Diagnostics for Windows

Are you able to test the drive on a different computer?