Cannot access my My Book World Edition (WD10000H1NC) anymore

Hi there,
i use my MyBook World Edtion in my LAN since a few years, i was always able to Access it via my local LAN… since yesterday it seems like the device doenst boot properly anymore…
as soon as i turn it ob, it starts working and it sounds like it boots normally, but however, i cannot access it via Network, no chance to reach it… I rebooted it a few times… i used the reset Switch at the back of the device… normally it should reset the device tpo use dhcp and so on, but i cannot reach the device via Network…
i used a Network scanner to broadcast my whole small Network, nothing! i find all my other devices but not my mybookworld…
how can i acceess my mybookworld again?! Help!

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Is support available for those legacy devices that are out of warranty? I thought that what this forum was for?

(EDIT: Spelling)

It seems that newest windows updates somehow disturb the nas. I was able to boot when there was no windows machine in network. Then I enabled SMB1 in windows (just google it) and have again access to NAS.
EDIT: access was only for a short time. My only solution is to boot NAS with Windows 10 PC turned off, and use some tablet or an old Windows XP to save data.

I have a similar issue. WD Support was unable to answer my question and told me my product was out of warranty. I told them it was out of warranty when I notified them.
Useless answers. I would have gotten a better response from my technically challenged wife…

I am having a similar problem, I have a windows 10 desktop and the white light network drive does not work. I cannot connect to it via the network router or directly connecting to the ethernet port of the desktop. WD Discovery just does not finds it. I have tried resetting the drive by pushing the button using the pin at the rear of the drive.

Check your power supply, multiple drives in this unit are quite power hungry.
If you listen to the unit and hear the drives stopping and starting then this will certainly be something to consider.
Hope this helps.

There are a few versions of the ‘reset procedure’ available online and WD admit there is an error in the operating instructions for the ‘My Book World Edition’, specifically the time you should hold the ‘reset button’ in for (manual says 4 seconds, which WD corrected to 20 seconds). I found the following procedure worked for me.

Power down, disconnect power cable and remove any expansion USB drives connected to the rear ‘USB port’.

If you have allocated a static IP to the unit, remove it from your router.

Attach the drive by ethernet to your network/router.

Connect power cable and wait for it to cycle on then off automatically. It does this so that a powered down unit doesn’t power up after a power cut.

Then press and HOLD the ‘Reset button’ and power up using the ‘Power button’ … hold the ‘Reset button’ for 60 seconds.

The unit will go in to a short ‘Transitioning to drive ready’ mode followed by a drive scan where the lights will move up and down as if the drive is in use, followed by a solid light when it is nearing completion. Let it finish.

The drives web UI username and password should have reset to admin, admin. The network settings should have reset to DHCP default.

Use the ‘WD link’ software or a Network scanner to locate the drive (it’s IP) on the local network.

Hope this works.