Cannot access my files and folders on Big Sur


I have a WD My passport 512Gb external ssd and mostly I use it with my MacBook Pro Early 2020 13" and since I upgraded to Bug Sur there is a really annoying issue… When I connect it I can see all my files and folders and after a few minutes (or seconds) everything is gone I reconnect it I can see them again, but there’s gonna be the same issue after another seconds/minutes.

I already reinstalled my WD Discovery app and also downloaded the version what they suggested for Big Sur, but that haven’t solved my problem. I also checked the cable what they recommended, but the issue came up with a different cable as well. Someone also recommended to connect it to another PC or Mac, but that also didn’t solve my problem (btw on Windows it’s working fine… there isn’t any similar problem). I’m sure there is an issue with Big Sur or WD Discovery.

I read a lot of posts and pages, but still didn’t find any solution what is working. Anyone has any other ideas?

Best wishes


I have the exact same problem as Mr D above. In my case I own 2 ea EasyStore 264D 8 Tb drives with each less than a year old. I have used both with my 2 iMacs (a 19,2 model and a 17,1 model). I love the drives except for the data “disappearing” after an hour or so. All I have found to relieve this is to reboot. I read on another forum that this might be a result of the drive not having enough power available after a sleep session to display the files. My About This Mac reports that the drive is pulling 6 mA and has 900 mA available. I turned off drive sleep but still have the same problem, with 2 identical drives hooked in various combinations with different cables all with the same result. Ideas, folks? If not I will have to return the drives which I don’t want to do.

Possible solution

So today I got kinda upset because of this issue and started looking for a solution again. Then I found this discussion at apple. I saw a recommendation to change the Energy Saver settings so I went to Battery settings and unchecked the “Put hard disks to sleep when possible” (on the photo it’s there at the top under the “Turn display off after”). If you’re using a MB then apply this at the “Battery” and also at the “Power Adapter”. After this I’d suggest to restart your mac if it’s necessary.

Although I did all this just today and it seems to work I’m still not sure this will solve my problem, but I’m gonna give a feedback after few days.

Oh and one more thing I also erased my ssd with an ExFat format since I also want to use it on Windows and I don’t use wd’s software. (For this step this video might be helpful, but might not be necessary… I’d recommend to try the first step at the beginning with unchecking)

Hope it will help and work. If there is any other suggestions I’m still open to them.

Best wishes