Cannot access my Book Live Duo

I have My Book Live, and My Book Live duo attached to my system over the home network.
Both devices worked fine for last few years.

However, in last few months I start having access problems with My Live Duo randomly. To resolve the access issue, I had to turn the unit off/on to get access. That worked for a while.

Now, I cannot access the device at all. Pls note that my other drive works fine, and accessible without any issue.

looking for suggestions.

AJ Mehrabian

Can you access the unit’s Dashboard? Is it detected by the WD My Cloud desktop app or the web file viewer? Is your router detecting it and assigning an IP address even if it can not be accessed?

Thank you for your reply.

1- No. It is not detected by WD Cloud desktop app
2- No. I do not see the unit under my router device list.

Also, I have connected the unit to a USB port, and I still cannot see the unit.


I have the same problem.
After I lost acess to the device, I ve made factory restore… and now one of 3 folders i had on my NAS is empty. All my fotos were there.
How did you resolve the problem?

Similar story: details as follows:

Drive connected to Apple Airport Extreme with shielded Cat 5e cable.

Front panel LED solid green. IP address fixed at; returns pings from Mac and Linux shells. Drive worked for a month or so after last firmware update. (2.43… I think, but admin panel reported firmware up-to-date.)

The drive now does not respond to HTTP calls to its IP address. Mac Finder windows display correct network name (Ted), report “connecting…” then “The drive may not exist or is unavailable at this time.” WD My displays “Ted” and IP address, but reports (a) invalid SSL certificate then (b) “failed to connect to device”.

The problem has survived multiple hard shutdowns, and resets using the recessed button in the rear panel.

Tentative diagnosis: networking hardware and connection OK; firmware corrupted.

A similar problem report in this forum drew from WD a suggestion that the drive is suffering “unit fatigue”. Hardware of course has a finite working life. But this RAID drive is designed and sold for securing valuable files. In duplicate. It is therefore reasonable to expect either that the device degrades gracefully, with timely warnings to replace it, or that there is a safe recovery path for the data if the drive is allowed to fail catastrophically.

WD needs to take a view on this. It seems to have a choice of two:

  1. There is a robust way to recover the contents to a new drive; or
  2. The drive does not warn when it needs replacing before catastrophic failure from “unit fatigue”, and was thus sold unfit for purpose.

The user manual describes how to recover from failure of one of the 3Tb disks: replace it and allow the drive some hours to restore the mirroring. If WD asserts (1) then a description of how to recover from drive failure is needed.

@Trancer, this was you on 21 Nov: MyBook Live Duo disconnecting from the network.

MBLD is responding to, but refusing, my SSH requests:

☕ ~sjt@Prudence:~$ ssh -v Admin@
OpenSSH_7.2p2 Ubuntu-4ubuntu2.1, OpenSSL 1.0.2g  1 Mar 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to [] port 22.
debug1: connect to address port 22: Connection refused
ssh: connect to host port 22: Connection refused