Cannot access MBL via FTP with FTP Rush program

I’ve got a pair of 3TB MBL drives and I’d like to transfer data from one to the other via FXP.  I found a great guide to doing that here:

I followed the directions but for some reason I cannot get connected with FTP Rush.  I have FTP enabled via the UI on both drives.  I have enabled SSH and changed the password and have no problem connecting with putty via SSH.  I have even connected with a program called psftp, so I think FTP access works (although I’m not sure what port that program uses).

The problem comes when I try to connect with FTP Rush.  I can connect via SSH fine, but that doesn’t allow passive mode, so it doesn’t allow me to transfer files (I guess FXP requires passive mode, right?).  I have tried the following:

  • Normal FTP Server

[1] Connecting to
[1] 220 “Welcome to MyBookLive”
[1] USER root
[1] 530 Permission denied.
[1] Retrying after 30 seconds for ftp://root:***@


[1] Connecting to
[1] 220 “Welcome to MyBookLive”
[1] 530 Please login with USER and PASS.
[1] Retrying after 30 seconds for ftp://root:***@


[1] Connecting to
[1] 220 “Welcome to MyBookLive”
[1] 530 Please login with USER and PASS.
[1] Retrying after 30 seconds for ftp://root:***@

Very strange that the last two attempts tell me to login with USER and PASS, since I have provided those already.  I did try SSL FTP (Implicit SSL) and TFTP and both also failed, but they go to ports other than 21, so I didn’t think those were correct anyway.  I tried this for both MBLs with no success.  I tried to mess with some settings like anonymous, but nothing I tried helped.

This seems like it should be a simple because I am not trying to use remote access or anything.  Both drives are on the local network with my computer. 

Does anyone have any ideas about what I might be doing wrong or can try?  I am open to trying a different program for FXP, but based on the thread I linked to, I don’t understand why I can get this to work.

Thanks for the help.

mine does the same. 

cannot log in using root as a username

what works for me is to create a new user in the MBL with full permissions.

Log into ftp with rush using that user and password. 


1 Like

OK, now I feel like an ■■■■■.  I just tried it using the USER admin and I was able to connect with Normal FTP Server and I’m now transferring.  Sorry to bother everybody. 

I had actually tried admin earlier, but it didn’t work.  I probably only tried it with the other SSL options which still don’t seem to work.  There are a lot of combinations to go through and I guess I missed the one that works :-). 

Transfer speeds are all over the place.  Really large files seem to typically be around 13 to 14 Mbps, which seems slow.  I have seen numbers as high as 60+ Mbps though.  I don’t know that there is anything I can do to improve this.  Both drives are connected directly to the same 1Gbps switch and nothing else is going on that switch.

I can’t complain since using FXP allows me to perfom the transfers without affecting my PC’s bandwidth to the internet.

Thanks a lot for the quick response Tgaguy.  I think that is essentially what I did by using the admin username.