Cannot access MBL from Windows but can from Mac

I have a My Book Live 2tb.  Its been working great for the past few months where my PCs, Macs, and Droid phones can all access the shares.  Usually I keep the MBL on a segment on the network where it can be seen from any local devices and cannot see the internet.

I gave the MBL access to the internet and  I ran the auto update that failed a few times but then brought me up  to 02.43.03-022

Now I cannot map to the MBL from the PCs or the Droids, only the Mac.  Its like SMB has been turned off or is not starting up.

I can ping the MBL, http to the admin page, get ot the shares from my MacBook.  I get “not able to reconnect” errors from my Win7 machine not being able to reconnect to the shares.  While in the admin screen on the MBL, I cannot find anywhere that talks about protocols it accepts.

I have rebooted the MBL and routers a few times but no joy.  When I port scan it, I see http, https, aft, and nfs.

Wanted to see if there are any better solutions before risking rolling it back to the previous 02.11???  version.



Have you tried powercycling the MBL?

Powercycle? yes, a number of times and still not working.