Cannot access G Speed ES web gui

Was working fine, but now cannot access the localhost:7402 web gui. I can see all my ES drives in Explorer but need to unmount a couple and mount some others.

Have tried Chrome, Firefox and Opera, they all give some form of
“Local host refused to connect”

The only thing I think changed was adding Avast recently. Tried uninstalling it but still no access


Forgot to mention am using Win 10

Have you tried reinstalling the Webgui? The software/drivers were never updated for Windows 10 as the OS was released prior to the support for the card ending. Highpoint the maker of the RAID controller updated their controller to the 644L and is now the supported card. They have a new webgui designed for that card.


If I reinstall the GUI will that affect my RAID configurations? I have two ES units. Am using Rocket Raid 2314. It’s been working fine with exception of the GUI and being able to mount/unmount drives. I have one unit configured as RAID 0 and am nervous about doing anything that might mess it up.


Also, where can I find the older web gui as my units came without installation discs?

Thanks again

The webGui’s don’t affect the RAID at all since those are handled by the hardware on the card, the webgui is just software for the computer. Reinstalling won’t affect the RAID.

We have the old G-Tech software on our site still. Support > Downloads > Software by Product > G-Speed eS


Thanks for your help. I see several Windows install options. Should I do XP or Vista?


Vista would have the most recent version.

Thanks Rydia
I’ll try Vista. It looked like everything is downloaded in the zip file, so does the web gui appear separately during install?

Sorry for so many questions, just concerned about screwing up my setup. Am trying to backup 8tb of files before doing this.

It is part of the install package in the zip file.

Great, thanks again!