Cannot access, format my WDTV Live HUB

I was looking at a movie the other day and my Live HUB 1 tb suddenly just hang up…? I couldn’t do anything with the remote or the on/off button on the hub so I had to pull the plug…

When I restarted the hub just kept compiling the library… Didn’t stop, so I tried to downgrade the firmware (to reinstall it again) but this didn’t work…

After reading the forum I tried to put all my files in a new catalog named “. My music”, the hub STILL just blinks and compiling the library…

Tried to format the whole disc? Nope, it just keeps going and blinking, nothing more…

Tried to remove it through my PC (win 7) sloooow and crashes all the time, 45 min for a 130 kb .jpg picture!!

What to do?? Is there any other way to format the disc?? Of course I bought it at eBay 

//Swede

Turn off the media library in the setup menu.

Then reboot it. 

Then try reformating it.

.

had to take the HD out and plug in the PC, discovered 3 partitions??

What to do? shall I just format it into one big HD or what?? Ideas??

When I said reformat, that meant to do it from the hub’s menu, not plugging it into a PC…

Yeah.

I tried that, but the hub freezes… Had to take the HD out…

Fixed it!

I took out the HD and formatted it in my PC Win7 (couldn’t format it in the hub). Made two partitions WDTVPriv and WDTVLiveHub.

Then downgraded (rollback) it to ver 2.07, had to pull the electric cable and then start the device with the USB memory in it to get the rollback to work?!?

After this it was as new? Just upgraded it to 2.08 and everything is fine.

I think it started with a corrupt file somewhere.