Cannot access files on My Book Elite

I beg the community for help.  I backed up vital files on a My Book Elite.  The laptop C: Drive was reformatted and now when it is time to restore the files from the WD My Book Elite, they cannot be accessed.  After a long wait, the option to install the software pops up but it hangs with 25 seconds to complete the installation and will not go any further.  I have tried this on two different laptops - one with Vista and one with Windows 7.   I thought that beyond the “E” Drive which was the one with the WD software that the files were actually on what was showing as the “F” drive, but I cannot open nor read any files on the drive at all.  Everything was fine when the files were backed up and I checked the WD My Book Elite on both laptops prior to reformatting the one with Vista operating system.

PLEASE HELP - how can I access the files without damaging the integrity of the data on the WD My Book Elite?!!  This is practically a life/death situation with requiring the data on that drive!!!   PLEASE HELP!!!


You were able to solve the issue?

No, unfortunately thus far, the problem still exists.  Per the suggestion of “pizzamaker” who has been very kind to respond and willing to make suggestions, I have searched for “smartware.swstor” and I also tried *.*swstor to The drive will plug in and windows (Vista) makes a sound like it recognizes a USB device, and after a REALLY long time, windows explorer finally shows an “E” drive which is: CD Drive (E:) WD SmartWare however, the files are not there and the software does not finish loading despite my download of the SES device driver and the smartware from the website.  

Very fearful of doing any firmware update IF there is a chance the data is still on that drive somewhare.  It showed up fine as the files and folders on the Vista laptop as well as a laptop running Windows 7 just a week or so ago when I backed up the drive - there was a “F” drive with all the data there.  Now, I cannot access any F drive…   What next?  Could the data still be there?  Deb from Australia