Cannot access data on My Passport portable 500GB

Have used successfully for a couple of years but today I tried to view some photos stored on the drive but couldn’t find them. The problem seems to be with photos that were filed in sub folders within My Passport (all sub folders appear to be there but folders have no content) as photos that were not in a sub folder could be viewed with no problem.

I use a MacBook Pro and the only thing that has changed since last time I used My Passport is that there has been a software update to OS X Yosemite 10.10.1

I’m really upset that the photos may be “lost” as there are many of great sentimental value so I hope there is a solution to this issue.


Welcome to the Community.

Do you have a backup of your data? Are the files seen if your hard drive is connected to another computer running Mac OS 10.9 or earlier in order to confirm if this issue is related to Mac OS 10.10?

Hi - stupidly, no I don’t have a backup - I assumed it would be safe on the external drive.

I don’t have access to any other Mac’s so can’t confirm.

Hi - received the following via e-mail:

Thank you for contacting Western Digital Support.
My name is [[Deleted - Trancer]].

I would like to apologize for all of the inconveniences which you experienced with our product.

Unfortunately we do not have enough information to provide you assistance.

Could you please provide me more detailed information about the problem which you have?

As soon I will receive required information we will be able to provide you further and more accurate assistance.

Have tried to respond but address not valid so this is my question:

Not sure what other information you need from me. I have explained what difficulties I am having, i.e. there is definitely data on the My Passport drive but all of what should be there cannot be viewed if it was filed in a sub folder.

If you could be a bit more specific about what you need, I will try to provide it.