Cannot Access Dashboard

Before we start - yes, I know the IP/hostname of my device and yes I know the password to my device. Also, I have tried the multiple different ways to reset the device to drop me to the default username/password…no dice.

That said - I cannot get past the login dashboard screen for my device. I know it is checking the password correctly cause when I enter it in wrong it tells me. If I enter it in correctly it just refreshes back to the login screen again (about a 1-2 second delay). I can access my files via the windows share just fine. For note - the device has a blinking green light 99% of the time. I have turned off iTunes sharing and offline mode. Still, nothing.

SSH is not enabled for me to update the firmware that way.

I know it is not my antivirus (tried it via my phone as well), or my router (I tried a different router and directly to my NIC).

Please advise how I can access the dash board again.


Hello and welcome to the WD Community.

Have you tried using a different browser? If yes and stills the same, as a troubleshooting step, connect the drive directly to your pc and see if you are able to connect.

Yes, I tried both. No luck.

The easiest and most definate way to solve your problem is to do  a debrick. There are debrick guides on this forum. You will not lose you data.

I think it was the NIC attached to the drive. Shortly after it never connected to the network. I took the NIC off and just pulled my files off. Piece of junk.