Can you connect 2 passports at the same time?

Whenever i connect 2 my passports my pc only shows one . Can this be done . If i connect 1 my passport an one of another brand my pc shows both .Thanks for your time an help.

Bill

Sometimes the drives come from the factory with the same “disk signature”, which is normally a 32-bit random ID number that’s created when you format a drive.

What I recommend is to plug in one My Passport, make sure there’s no data on it, and then format your My Passport.  That’ll give it a new disk signature and after that you shouldn’t have any problem using both drives at once.

Or With both Drives Connected at the Same time You Can Go to Disk Management And 1 of the HDs Will

Be Offline in there , the Only thing that you need to do is a right Click on the Drive Offline and mark it  Online and Both of them Will Be recognized at the same time :slight_smile:

1 Like

Yes, that’s definitely true, and it will work great, especially if each drive has a lot of data on it, so I’m glad you mentioned it.  :smiley:

But reformatting one of the drives will ensure that the problem doesn’t happen on other computers either.  Since these were new drives, that’s why I recommended the reformat.

hey i too had the same problem connecting 2 passports

one gives me the general option to explore the hard drive

but the hard drive connected  second runs the autoplay options and i cannot view my content

as per your advise i did format one of my hard drive

BUT the problem still persists…

can ya plz help me.

hey how do i go to disk management in my windows 7

i tried to look for it in  control panel but couldn’t find it

do i have to fill up my hard drive to get this option?

as i have already formatted one of my hard drive

But the problem still persists

The easiest way to access Disk Management in any version of Windows is:

  1. click on the Start Menu

  2. right-click on Computer or My Computer

  3. click on Manage in the popup menu.

  4. when the Computer Management console comes up, click on Disk Management near the bottom of the left column.

I DISAGREE!!

The easiest way to access Disk Management in any version of Windows is:

Click in the Start Menu , Open ‘‘RUN’’ Utility and Type diskmgmt.msc That’s It!!! Easier and Simple :slight_smile:

1 Like

I disagree, because that’s harder to remember!  (Also, not everyone has a Run menu, so Windows Logo + R would be easier)

I knew someone would bring that method up, but i decided that was the “quickest” way instead.  :wink:

It’s just like everything else in computers–there are lots of ways to do something but not necessarily a “right” way to do something!

hey thank u guys…

the disk mgmt thing worked fine…

well about the argument on which is the easiest way…

its actually subjective…

but nathan’s answer is more for common layman level users

so that sounds more easier to me…

even the run option is perfect (i did that)

anywaz thanks for your help…

make sure u guys read harry potter to know who i am

One who must not be named.

Hi

I have the “same” problem, but when I connect the second disk, the first disappear, and the second also.

In managment console, I have only my system HDD, not external WD passport. !!!

hey my prob was solved by nathan… he’'ll solve your too… good luck bye.