Can write data into WD MyCloud DUo but cannot copy files out

I have the WD MyCloud Home DUO 16 TB which I purchased from NewEgg. I have two Windows 10 64 bit computers accessing it on the same network. Each computer has the WD Discovery on the task bar and map to the DUO drive via a drive ID. The WD Discovery shows all the drives I have including this DUO drive. So far so good. I began copying files into the Duo for about two weeks. Today I tried to copy some files out but to my surprises, I am getting an error message as soon as I do the copy. The unexpected error is 0x80004005. I tried on another machine… NO LUCK. I Googled this error to no avail. Other people has problem accessing the drive but in my case, the setup is by the book and the drive works well in letting me copy stuff to it. I installed the WD Utility which is on the WD Discovery but it does not see anything. In summary, I have the DUO working only getting files into it, not getting out. Please help ASAP.



@ivysoft please check access using the My Cloud Home web and mobile app.

On the web interface, I can rename folder but I cannot view the file names and their types.

On the network drive, I can see those folders and file names clearly. I can play MP4 without any issue. The error I reported happens when I try to copy file out of the MyCloud drive. (using copy and paste, for example.)

On the iPhone, I only use it to view MP4 files on the phone. I can see those files with full file names. My observation is that it is very slow so the sound become choppy. I have a fast internet at home but the play back is not satisfactory. The sound has the pop pop choppy during each sentence like every other second.



more screen shot:

On the web interface: The folder names are shown but the file names do not.


Can somebody at WD please answer my question? My problem has not been solved.