Can WD TV Live Hub play ripped DVDs?

I have lot of DVDs (paid owner) and will like to rip them into digital format and save to a network drive or to Hub’s drive. Has anyone done this? what are the formats we should rip into? some threads are mentioning hub can’t play VOB file and another thread mentioned save it as ISO (both using dvd shrink).

My questions are:

a) can hub play ripped DVDs?

b) what format we should save ripped DVDs to?

c) what is the best ripping software that will do a) and b) for us

thanks a lot!

a)  Yes.

b)  I prefer ISO format.

c)  I prefer DVDFab.

Does DVDFab compress them to a small file i dont want to fill my media box with very large files

Dvdfab can compress, checkout

http://www.dvdfab.com/dvd-copy.htm

from dvdfab website:

DVDFab DVD Copy makes perfect 1:1 ratio DVD clone, and can also compress DVD-9 to a single DVD-5 with amazing output effect.

Ripping and saving as VIDEO_TS files also works well.

Just got a WD TV Live Hub.    I use Pinnacle Studio to create DVDs of home movies, which burn and play perfectly.   I keep a back-up Video_ts copy of all my movies in case I need to burn further copies.   I have copied several of these folders to my Live hub, but they only play straight through from the beginning and I cannot access the DVD menus.   How is DVD navigation achieved?

Press the ‘Option’ key on the remote, and then you can select ‘Menu’ on the screen that comes up.

Thanks for that advice.   I was already aware of that from page 47 of the manual.   I have all of my files (VOB, etc) inside a video_ts folder as normal but the Options button threw up a context menu which did not include the MENU option.

Last night I used IMGBurn to create an iso image of my home movie DVD and I used this to stream to my Live Hub.   This time, when I press Options I see a ‘Menu’ option at the top of the list.   This accesses the DVD menu, and everything worked OK.

Still, the manual implies that menus should be available from video-ts folders, and does not say anything about needing to convert to iso.

I have a lot of DVDs to image just to see them on my Live Box.   As I prefer to keep them on my PC as video-ts, which I play with Powerdvd, and which I can re-burn to a blank disc within Pinnacle Studio, then I am going to need a lot more hdd storage just to get dvds to work on the Live Box!

They SHOULD be.   

Here’s a dumb question.  The folder should be named VIDEO_TS, not VIDEO-TS.  Is that how you’ve named them?

Don’t mind you asking the question, but yes, they are Video_ts folders.

To be honest this box is turning out to be a real PITA, but I have an analytical mind and I don’t give up easily.   I spent the morning creating iso files from IMGBurn and transferring them to the Live Hub.

Whem I tested the Live Hub nothing seemed to work, so I re-booted.   I have tested all of my video-ts and iso videos on the box and have come to the following consistent conclusions:-

iso videos will provide a Menu option under the option button when the video is ‘resumed’ from the list on the screen.   If the iso video is allowed to preview in the window and started from there then the Options button displays the following list:

                           Get Content info

                           Audio

                           Audio lip sync

                             … etc

                             … etc

Therefore if I exit the video, restart and ‘Resume’ the Options button displays:

                           Menu

                           Subtitle

                           Audio

                           Get Content Info

… and selecting ‘Menu’ will display my dvd menu.

So, even with iso there is a (slight) problem, though not insurmountable.   I just don’t allow the video to preview.

Now here’s the real problem.    I can’t get video_ts dvds to Resume.   They just freeze.   If I highlight the movie in the list, wait for it to preview in the window, then it will play from the start, but I don’t get a ‘Menu’ option!

Now, is someone going to tell me that this is how this is supposed to (not) work?

afficionado, I’m sorry I can’t be of any help, but I’ve never encountered the issues of which you speak. I can’t understand why our experiences have been so different.

I’ve begun using the Hub more and more to play VIDEO_TS stuff, because it puts out a better looking picture than my upconverting dvd player.

OK - it’s a mystery.    I have changed from ‘Preview’ to ‘list’ view in the video menu.   This ensures that I can always access the dvd menu when I select and start an iso dvd.

Still, I envy you, as I would prefer to work with video_ts folders and files.   The video_tx dvd is still not working.   I’ll copy some others over to the Live hub and continue to experiment.

I am on the latest firmware.    I was inclined to think this was a bug, but if you are having no problems with menus on video_ts files then I am a little perplexed as to what I can do.

Hi,

Do you have VIDEO_TS as upper case?

VIDEO_TS is in upper case.   The files and folders are copied over from my PC exactly as they appear on my C: Drive.   I have dozens of them and they all work perfectly on my desktop PC.   I can copy them to DVD-Rs and they play perfectly.   I always create menus for my home movies.    I can play them in Windows Media Player with menus.    They play with Powerdvd.   I can burn using Nero, or Pinnacle Studio.   I have been doing this for years.   I have tended not to use IMGburn and store as image files.   Guess I may have to start.

Referring to my earlier post, I am coping with creating iso files in order that I can play my movies back and navigate via the DVD menus I have created (notwithstanding the issue I reported as a result of the Preview Window - is anyone else seeing this symptom with iso files?).

But obviously I am concerned at having to retain both a VIDEO_TS and an iso copy of all my movies.

I have been testing the  WD TV Live Hub all day, and the symptoms I reported earlier persist.    I have copied the individual mpeg .VOB files which constitute my dvds and individually these all play fine on the WD Live.

On a couple of occasions pressing the Back button on the remote has caused ‘a Fatal device error’, causing the box to shut down and restart.   Now that smells of flaky firmware to me.

I have been designing and testing systems for years and don’t mind digging to resolve issues.   If I am the only person who can’t play VIDEO_TS files on his Live Box (with menus) then I accept that I am missing something.

Thanks for all the interest and assistance.   It would reassure me if someone else reported the same then we could flag it as a bug, but whilst I have only heard from people who maintain that it works for them (menu navigation with VIDEO_TS files) then I must assume something other than firmware.

My home movies are all created in Pinnacle Studio 14.   I may try a quick edit in Nero and create a VIDEO_TS file there to see what happens.

Thanks guys

Well, you got so many things going on, I don’t know what you’re saying is the issue.  :)

But let me explain it this way:

If you launch a DVD from the PREVIEW screen (as in hitting OK on the Preview window) it will not have DVD menu navigation.   That is by design, because the interactivity is not considered PREVIEWING.   If it were to bring up a menu in the PREVIEW window, you’d have no way to interact with it since the cursor keys are controlling the WD’s UI, not the DVD menu.

What you’re wanting is to LAUNCH the DVD.   So, even if it’s playing in the preview window, if you hit ENTER on the TITLE (instead of the Preview window) it should re-launch from the beginning, or at a RESUME point if it was previously viewed.

In Any other VIEW mode OTHER than Preview, you will always get the Menu.   And you will also be allowed to RESUME a previously watched video.   With DVDs, it’s actually rather handy, because it will also RESUME you INTO the MENU.

So, do all your concerns go away if you use a different VIEW mode?   In other words, is it just a confusion over how the PREVIEW view works?

1 Like

Excellent well-laid out answer - thanks.   So I now understand the Preview Window, given your rationale.   That was down to my lack of familiarity with the gui.

So, there only remains the issue of my not being able to navigate the menu structure on a VIDEO_TS, and that’s because I can only start the movie from the preview window, which plays the movie straight through.

When I click on the file name to the left of the window I get the option to Resume or Restart, and neither will work.   Whichever I choose I briefly see the Video Playback Panel with the word ‘Closed’ in orange and then the screen goes blank.

I have attempted this in ‘Gallery’ and other Video menu views.

Thanks for helping me drill down to the nub of the problem.      I feel I may be getting somewhere - or should I say you have guided me there.

Thanks

afficionado wrote:

Whichever I choose I briefly see the Video Playback Panel with the word ‘Closed’ in orange and then the screen goes blank.

Huh.  That’s odd.  I’ve NEVER seen a “Video Playback Panel” with any words in it.

Is it displayed long enough that you migth get a SCREENSHOT using the Hub’s Screen Capture function? (It’s set up by setting a Remote Hotkey and will save the screenshot to the internal HD.)

If you have access to the manual, or can look at the pdf online, on Page 46 - Watching Video, there is a screen-shot of a Video Playback Panel on the bottom of the screen for the movie ‘Nature’.  I see ‘Close’ in orange, but not ‘Skip To desired Time’ as in the example in the manual.

The Video Playback Panel is displayed on the bottom of a blank screen after I select either Resume or Restart, and then everything goes blank ( a bit like my brain at the moment!).

Thanks for your persistence.

Well, this has remained a complete mystery to me, though now only a minor annoyance/disappointment.

I can play all of my mpeg .VOB (copied from my Video_TS folders on my C: Drive) individually, but they won’t play on the WD Live hub as part of a copied VIDEO_TS folder.

The iso files that I am slowly creating on my PC from the VIDEO_TS folders will all play OK with full menu navigation.   I just need to buy a new hdd to store them all, or give up on retaining the original VIDEO_TS folders for back-up.

So, the WD LIVE box ticks most, though not all, of the requirements.   I am playing AVCHD .m2ts successfully, and have tested all of the file types I would need.

I’ll class this as a minor irritation and hope that whatever is wrong is corrected at some future point, at which time i will probably be working exclusively with isos.

Being the stubborn type, I am continuing to plug away to resolve why my new WD TV Live hub can’t play VIDEO_TS dvds.   But I am still perplexed.    I have accessed the Live hub drive remotely from my desktop PC and I can launch the dvds in the VIDEO_TS folders with no problems.   On my desktop, the .vob I select launches Windows Media Player without a problem.   This is a screen-shot of the contents of the VIDEO_TS folder on my WD Live.   Apart from the ‘Thumbs’ file it is identical to the on on main PC.

WD Live screen shot.jpg