Can’t Setup My Cloud Home Duo - Getting Invalid Code error

A couple of days back i got a New WD My Cloud Home Duo 12 TB Version.

When i try to set it up i get the Error relating to the Code.
I have tried All the Troubleshooting that i could do.
I am able to access the Public folder when accessing the IP address of the Home Duo and even copy files to it.

I have a TP-Link TL-R470T+ with 2 Internet ISP connected to it. I have a Gigabit TP-link Switch connected to it and then i have my laptop and another ASUS Dual Band Gigabit router and the Home Duo connected to it.

I have tried to Reset the Home Duo and also tried to connect it to the ASUS Gigabit router instead of the Switch but i still get the same result.

Any help on this would be Appreciated.

Hi lloydisaac,

We have sent you a message. Please check your Community Message Inbox.

Hi Brandon, I received my Replacement Home Duo, But unfortunately i am getting the exact same error

I did the steps that was mentioned for the first time setup.

after about a Minute the Light was on and not blinking.
Than i tried the setup - which did not work and again gave me the ops something is not matching up error.

After a Few minutes my home Duo automatically restarted and twice - may be the Firmware was updating, The light came back steady after a minute.

I again tried the Setup[ and got the same error. Please help me on the same

Have you tried pressing and holding the reset button for 60 seconds? That is supposed to reset the unit to factory settings and remove it from the WD servers. Once completed it should send you an email at the registered account saying it has completed. Then you can re-do the setup. Also, check to see if double-NAT or VPN is being used.

I have not tried that will try that.

I have a TP-Link R470T+ load balancer router that has 2 x 100mbps ISP connected, a TP-Link 1 gig switch connected and the Wd home duo connected to the switch as my laptop.

I have DHCP enabled on the router as well as UpnP enabled.

From my laptop I can connect to the wd home via the IP address and I can see the public folder.

Regarding the Double NAT, When i do a tracert to
I get only the first line as a private IP : which is my Router IP