Can’t safely remove Elements Desktop 1TB

Hello ladies and gentlemens, 

I’ve longer the problem with my WD Elements Desktop 1TB external drive that I can’t safely remove it from my notebook. Every time the message appears that the device is still in use. All I can do is to shut down my notebook to disconnect the device.

I tried a lot of things now but it hasn’t change anything so far, so hopefully someone here can help me with problem.

Let me begin with the general informations:

Windows: Win 7 32bit

Antivirus: Avast! Free Antivirus 2014

external Drive: WD Elements Desktop 1TB USB2 connect to USB2 Port on the notebook.

Problem: Device can’t be safely removed, message appears that the device is still in use. I need to shut my notebook down.

What I checked so far:

  1. Is any program opened (media player, file manager, browser etc.) ? No nothing is running, Windows is running in idle.

Is there any copy/reading process from the drive running ? No, no process like this is running.

Is there any folder/file opened from the drive ? No, there’s nothing in use from the drive.

Is there a backup program running ? I don’t have a backup program installed.

Is a WD program running ? I don’t have any program installed from Western Digital.

  1. I thought that this problem could be triggered by my Antivirus program. So I first opened the Antivirus program and watched which files are actually scanned. But there were now files of the external drive scanned just some from my system drive. 

Next try was to totally deactivate the program, but no change the device still can’t disconnectect.

The Antivirus program now can be excluded I think.

  1. Then I opened the Task Manager to check if some unusual process is running, but there is nothing unusual. I don’t have any other opened windows is running idle. I killed the explorer.exe and start the process new, also no change. 

I did a windows reboot to check if I can disconnect the drive directly after a new start. But no, still the message that device is in use.

Next step was a look in the device manager if there is a problem with the device or if it is recognized as an unknown device. But no, the device is recognized without any problems.

  1. Use the program Process Explorer with the handle option to the check if a process is using the device. But no process is accessing to the device.

Further things done:  - deactivated the indexing for the device, no change.

                                   - checked the drive policies, it’s optimized for quick removal. 

                                   - changed the device letter, no change.  

You see I tried a lot of things which I could find with Google. But no improvement so far and it gets really annoying. It’s a very strange thing with that WD device,  a Samsung external device can be disconnected without any problems, also at the same usb-port. 

So hopefully someone here has the final idea.

Hello, try to uninstall the USB driver and then reinstall it again. Also try connecting the Elements to another PC to verify if the problem continues. 

The uninstall of the USB driver and reinstall also doesn’t change anything I still can’t safely remove the device on my notebook.

I also tried the device at a Win7 32bit Desktop PC where the device could be removed successfully. So it seems to be a problem with the device and my notebook.


I found the problem with the program Zentimo now. It was the Windows Media Player Network Sharing Service (wmpnetwk.exe) which always used my drive. So I deactivated this service and now I can safely remove my drive.